blob: dc1568a77c9a66bd946e731dadf5d9deff351a58 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
Brad Bishop19323692019-04-05 15:28:33 -04005LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
8PV = "4.3+gitr${SRCPV}"
9SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d"
10SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
Patrick Williamsd7e96312015-09-22 08:09:05 -050011 file://0001-mksquashfs.c-get-inline-functions-work-with-C99.patch;striplevel=2 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 file://squashfs-tools-4.3-sysmacros.patch;striplevel=2 \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013 file://fix-compat.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080014 file://0001-squashfs-tools-patch-for-CVE-2015-4645-6.patch;striplevel=2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
18SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
19
20S = "${WORKDIR}/git/squashfs-tools"
21
Brad Bishop15ae2502019-06-18 21:44:24 -040022# needs FNM_EXTMATCH
23COMPATIBLE_HOST_libc-musl = 'null'
24
Brad Bishop19323692019-04-05 15:28:33 -040025EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
26
27PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr"
28PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib"
29PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz"
30PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo"
31PACKAGECONFIG[lz4] = "LZ4_SUPPORT=1,LZ4_SUPPORT=0,lz4"
32PACKAGECONFIG[lzma] = "LZMA_XZ_SUPPORT=1,LZMA_XZ_SUPPORT=0,xz"
33PACKAGECONFIG[xattr] = "XATTR_SUPPORT=1,XATTR_SUPPORT=0,attr"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
35do_compile() {
36 oe_runmake mksquashfs unsquashfs
37}
Brad Bishop19323692019-04-05 15:28:33 -040038
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039do_install () {
40 install -d ${D}${sbindir}
41 install -m 0755 mksquashfs ${D}${sbindir}/
42 install -m 0755 unsquashfs ${D}${sbindir}/
43}
44
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045ARM_INSTRUCTION_SET_armv4 = "arm"
46ARM_INSTRUCTION_SET_armv5 = "arm"
47ARM_INSTRUCTION_SET_armv6 = "arm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048
49BBCLASSEXTEND = "native nativesdk"
Brad Bishopc342db32019-05-15 21:57:59 -040050
51CVE_PRODUCT = "squashfs"