blob: c8ccff6f40dc55215be096a915fd5640bcebc8bd [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Linux libcamera framework"
2SECTION = "libs"
3
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
Brad Bishope42b3e32020-01-15 22:08:42 -05005
6LIC_FILES_CHKSUM = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007 file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
8 file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
Brad Bishope42b3e32020-01-15 22:08:42 -05009"
10
Patrick Williams8e7b46e2023-05-01 14:19:06 -050011SRC_URI = " \
12 git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
Patrick Williams169d7bc2024-01-05 11:33:25 -060013 file://0001-mojom-Drop-using-imp-module.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050014"
Brad Bishope42b3e32020-01-15 22:08:42 -050015
Patrick Williams2a254922023-08-11 09:48:11 -050016SRCREV = "960d0c1e19feaf310321c906e14bd5410c6be629"
Brad Bishope42b3e32020-01-15 22:08:42 -050017
Patrick Williams2390b1b2022-11-03 13:47:49 -050018PE = "1"
Brad Bishope42b3e32020-01-15 22:08:42 -050019
20S = "${WORKDIR}/git"
21
Patrick Williams2194f502022-10-16 14:26:09 -050022DEPENDS = "python3-pyyaml-native python3-jinja2-native python3-ply-native python3-jinja2-native udev gnutls chrpath-native libevent libyaml"
Brad Bishope42b3e32020-01-15 22:08:42 -050023DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
24
Andrew Geisslerd688a012020-09-18 13:36:00 -050025PACKAGES =+ "${PN}-gst"
26
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
29
Patrick Williamse760df82023-05-26 11:10:49 -050030LIBCAMERA_PIPELINES ??= "auto"
31
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000032EXTRA_OEMESON = " \
Patrick Williamse760df82023-05-26 11:10:49 -050033 -Dpipelines=${LIBCAMERA_PIPELINES} \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000034 -Dv4l2=true \
35 -Dcam=enabled \
36 -Dlc-compliance=disabled \
37 -Dtest=false \
38 -Ddocumentation=disabled \
39"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
Brad Bishope42b3e32020-01-15 22:08:42 -050042
43inherit meson pkgconfig python3native
44
Patrick Williams213cb262021-08-07 19:21:33 -050045do_configure:prepend() {
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070046 sed -i -e 's|py_compile=True,||' ${S}/utils/ipc/mojo/public/tools/mojom/mojom/generate/template_expander.py
47}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049do_install:append() {
Patrick Williams2390b1b2022-11-03 13:47:49 -050050 chrpath -d ${D}${libdir}/libcamera.so
Patrick Williams2a254922023-08-11 09:48:11 -050051 chrpath -d ${D}${libexecdir}/libcamera/v4l2-compat.so
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050052}
53
Andrew Geissler20137392023-10-12 04:59:14 -060054do_package:append() {
55 bb.build.exec_func("do_package_recalculate_ipa_signatures", d)
56}
57
58do_package_recalculate_ipa_signatures() {
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050059 local modules
60 for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do
61 module="${module%.sign}"
62 if [ -f "${module}" ] ; then
63 modules="${modules} ${module}"
64 fi
65 done
66
67 ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}"
68}
69
Patrick Williams2a254922023-08-11 09:48:11 -050070FILES:${PN} += " ${libexecdir}/libcamera/v4l2-compat.so"
Patrick Williams2390b1b2022-11-03 13:47:49 -050071FILES:${PN}-gst = "${libdir}/gstreamer-1.0"
Andrew Geissler517393d2023-01-13 08:55:19 -060072
73# libcamera-v4l2 explicitly sets _FILE_OFFSET_BITS=32 to get access to
74# both 32 and 64 bit file APIs.
75GLIBC_64BIT_TIME_FLAGS = ""
76