blob: 5acdcfb9f0407febb45544aab6a3b3a342faeb15 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Joel Stanleye252c312017-12-14 15:11:12 +103016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
23PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
24PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025# libaudit support would need scripting to be enabled
26PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
28
29# libunwind is not yet ported for some architectures
30PACKAGECONFIG_remove_arc = "libunwind"
31PACKAGECONFIG_remove_riscv64 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033DEPENDS = " \
34 virtual/${MLPREFIX}libc \
35 ${MLPREFIX}elfutils \
36 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040037 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038"
39
40do_configure[depends] += "virtual/kernel:do_shared_workdir"
41
42PROVIDES = "virtual/perf"
43
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
46# needed for building the tools/perf Python bindings
Brad Bishop316dfdd2018-06-25 12:45:53 -040047inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'pythonnative', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048inherit python-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049export PYTHON_SITEPACKAGES_DIR
50
51#kernel 3.1+ supports WERROR to disable warnings as errors
52export WERROR = "0"
53
54do_populate_lic[depends] += "virtual/kernel:do_patch"
55
56# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
59inherit kernelsrc
60
Brad Bishop316dfdd2018-06-25 12:45:53 -040061S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062SPDX_S = "${S}/tools/perf"
63
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064# The LDFLAGS is required or some old kernels fails due missing
65# symbols and this is preferred than requiring patches to every old
66# supported kernel.
67LDFLAGS="-ldl -lutil"
68
69EXTRA_OEMAKE = '\
70 -C ${S}/tools/perf \
71 O=${B} \
72 CROSS_COMPILE=${TARGET_PREFIX} \
73 ARCH=${ARCH} \
74 CC="${CC}" \
75 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060076 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077 EXTRA_CFLAGS="-ldw" \
Joel Stanleye252c312017-12-14 15:11:12 +103078 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050079 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103081 ${PACKAGECONFIG_CONFARGS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080082 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040083 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084'
85
86EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050087 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050088 'prefix=${prefix}' \
89 'bindir=${bindir}' \
90 'sharedir=${datadir}' \
91 'sysconfdir=${sysconfdir}' \
92 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050093 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
94 'sharedir=${@os.path.relpath(datadir, prefix)}' \
95 'mandir=${@os.path.relpath(mandir, prefix)}' \
96 'infodir=${@os.path.relpath(infodir, prefix)}' \
97"
98
Brad Bishopd5ae7d92018-06-14 09:52:03 -070099# During do_configure, we might run a 'make clean'. That often breaks
100# when done in parallel, so disable parallelism for do_configure. Note
101# that it has to be done this way rather than by passing -j1, since
102# perf's build system by default ignores any -j argument, but does
103# honour a JOBS variable.
104EXTRA_OEMAKE_append_task-configure = " JOBS=1"
105
Brad Bishop316dfdd2018-06-25 12:45:53 -0400106PERF_SRC ?= "Makefile \
107 include \
108 tools/arch \
109 tools/build \
110 tools/include \
111 tools/lib \
112 tools/Makefile \
113 tools/perf \
114 tools/scripts \
115"
116
Joel Stanleye252c312017-12-14 15:11:12 +1030117PERF_EXTRA_LDFLAGS = ""
118
119# MIPS N32
120PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
121PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
122
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123do_compile() {
124 # Linux kernel build system is expected to do the right thing
125 unset CFLAGS
126 oe_runmake all
127}
128
129do_install() {
130 # Linux kernel build system is expected to do the right thing
131 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500132 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500133 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030134 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135 oe_runmake DESTDIR=${D} install-python_ext
136 fi
137}
138
Brad Bishop316dfdd2018-06-25 12:45:53 -0400139do_configure[prefuncs] += "copy_perf_source_from_kernel"
140python copy_perf_source_from_kernel() {
141 sources = (d.getVar("PERF_SRC") or "").split()
142 src_dir = d.getVar("STAGING_KERNEL_DIR")
143 dest_dir = d.getVar("S")
144 bb.utils.mkdirhier(dest_dir)
145 for s in sources:
146 src = oe.path.join(src_dir, s)
147 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800148 if not os.path.exists(src):
149 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400150 if os.path.isdir(src):
151 oe.path.copyhardlinktree(src, dest)
152 else:
153 bb.utils.copyfile(src, dest)
154}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500155
Brad Bishop316dfdd2018-06-25 12:45:53 -0400156do_configure_prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157 # If building a multlib based perf, the incorrect library path will be
158 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
159 # build, with a 64 bit multilib, the arch won't match and the detection of a
160 # 64 bit build (and library) are not exected. To ensure that libraries are
161 # installed to the correct location, we can use the weak assignment in the
162 # config/Makefile.
163 #
164 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
165 # for kernel sources that do not already do this
166 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
167 # with each other if its in the shared source directory
168 #
169 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600170 perfconfig="${S}/tools/perf/config/Makefile"
171 fi
172 if [ -e "${S}/tools/perf/Makefile.config" ]; then
173 perfconfig="${S}/tools/perf/Makefile.config"
174 fi
175 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500176 # Match $(prefix)/$(lib) and $(prefix)/lib
177 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
178 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
179 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600180 ${perfconfig}
181 fi
182 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
183 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
184 # will use the relative path 'share/man', in the way it will resulting in
185 # incorrect installation for man pages.
186 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
187 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500188 fi
189 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
190 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
191 ${S}/tools/perf/Makefile.perf
192 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
193 ${S}/tools/perf/Makefile.perf
194 fi
195 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500196 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500197
198 if [ -e "${S}/tools/build/Makefile.build" ]; then
199 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
200 ${S}/tools/build/Makefile.build
201 fi
202
203 # We need to ensure the --sysroot option in CC is preserved
204 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
205 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
206 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600207 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500208 fi
209 if [ -e "${S}/tools/lib/api/Makefile" ]; then
210 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
211 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600212 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500213 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500214 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
215 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
216 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
217 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500218 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
219 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
220 fi
221 if [ -e "${S}/tools/build/Makefile.feature" ]; then
222 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
223 fi
224
225 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
226 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
227 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
228 fi
229 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
230 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
231 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
232 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500233
234 # use /usr/bin/env instead of version specific python
235 for s in `find ${S}/tools/perf/scripts/python/ -name '*.py'`; do
236 sed -i 's,/usr/bin/python2,/usr/bin/env python,' "${s}"
237 done
Brad Bishop19323692019-04-05 15:28:33 -0400238
239 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
240 # so we copy it from the sysroot unistd.h to the perf unistd.h
241 cp ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500242}
243
244python do_package_prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500245 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500246}
247
248PACKAGE_ARCH = "${MACHINE_ARCH}"
249
250
251PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
252
253RDEPENDS_${PN} += "elfutils bash"
254RDEPENDS_${PN}-archive =+ "bash"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400255RDEPENDS_${PN}-python =+ "bash python python-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500256RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
257RDEPENDS_${PN}-tests =+ "python"
258
Joel Stanleye252c312017-12-14 15:11:12 +1030259RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500260RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
261
Brad Bishop19323692019-04-05 15:28:33 -0400262FILES_SOLIBSDEV = ""
263FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent ${libdir}/libperf-jvmti.so"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500264FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500265FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400266FILES_${PN}-python = " \
267 ${PYTHON_SITEPACKAGES_DIR} \
268 ${libexecdir}/perf-core/scripts/python \
269 "
270FILES_${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500271
272
273INHIBIT_PACKAGE_DEBUG_SPLIT="1"