blob: d3fb644dfd1f9abf18821054998f26a1dcf50cfc [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008PV = "18.05.00+git${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010SRCREV = "b0ec7aa2ef743d113fd8c5e57c0ca3d5edd86f0e"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
12 file://0001-ignore-constant-logical-operand-warning-with-clang.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
14 file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
15 file://0003-Undefine-PAGE_SIZE.patch \
16 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018 file://0001-Remove-Werror-from-build.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21S = "${WORKDIR}/git"
22
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025DEPENDS = "libpcre json-c glib-2.0 dtc bison-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028inherit autotools bash-completion pkgconfig
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029
30CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031LDFLAGS_append_libc-musl = " -lexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032
33FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
34FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
35FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
36FILES_${PN}-dbg += "${libdir}/fwts/.debug"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037
38TOOLCHAIN = "gcc"
39