blob: c94aa0c28100bd2b5bf3016f5f1c302beabf201b [file] [log] [blame]
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
Tom Josephf6785aa2021-06-15 07:12:34 -07003DEPENDS += "function2"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05004DEPENDS += "systemd"
Matt Spinlere2375b52020-01-20 14:09:47 -06005DEPENDS += "sdeventplus"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05006DEPENDS += "phosphor-dbus-interfaces"
7DEPENDS += "nlohmann-json"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05008DEPENDS += "cli11"
Manojkiran Edac5934752022-09-27 13:59:35 -05009DEPENDS += "libpldm"
Riya Dixit1b221332023-03-28 01:42:41 -050010DEPENDS += "phosphor-logging"
Ed Tanous9936f862022-09-19 09:13:20 -070011PV = "1.0+git${SRCPV}"
12PR = "r1"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050013
14S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050015SYSTEMD_SERVICE:${PN} += "pldmd.service"
16SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
Deepak Kodihallia7482012020-06-22 05:25:35 -050017
Ed Tanous9936f862022-09-19 09:13:20 -070018inherit meson pkgconfig
19inherit systemd
20
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050021EXTRA_OEMESON = " \
22 -Dtests=disabled \
23 -Doem-ibm=disabled \
24 "
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050025
Ed Tanous9936f862022-09-19 09:13:20 -070026pkg_prerm:${PN} () {
27 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
28 rm $LINK
29 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
30 rm $LINK
31}
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050032# Install pldmSoftPowerOff.service in correct targets
Patrick Williams12fc9392021-08-06 09:16:53 -050033pkg_postinst:${PN} () {
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053034 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
35 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050036 TARGET="../pldmSoftPowerOff.service"
37 ln -s $TARGET $LINK
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053038 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
39 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050040 TARGET="../pldmSoftPowerOff.service"
41 ln -s $TARGET $LINK
42}
43
Ed Tanous9936f862022-09-19 09:13:20 -070044require pldm.inc