blob: 37e2ba6690d4680686c76a35403d2c8c0bbeeab6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ltrace intercepts and records dynamic library calls"
2
3DESCRIPTION = "ltrace intercepts and records dynamic library calls \
4which are called by an executed process and the signals received by that process. \
5It can also intercept and print the system calls executed by the program.\
6"
7HOMEPAGE = "http://ltrace.org/"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
11
12PE = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013PV = "7.91+git${SRCPV}"
14SRCREV = "c22d359433b333937ee3d803450dc41998115685"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16DEPENDS = "elfutils"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018 file://configure-allow-to-disable-selinux-support.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060019 file://0001-replace-readdir_r-with-readdir.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020 file://0001-Use-correct-enum-type.patch \
21 file://0002-Fix-const-qualifier-error.patch \
22 file://0001-ARM-code-has-unreachable-code-after-switch-statement.patch \
23 file://0001-Fix-tautological-compare-warning.patch \
24 file://0001-Add-support-for-mips64-n32-n64.patch \
25 file://0001-configure-Recognise-linux-musl-as-a-host-OS.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026 file://0001-mips-plt.c-Delete-include-error.h.patch \
Brad Bishop19323692019-04-05 15:28:33 -040027 file://0001-move-fprintf-into-same-block-where-modname-and-symna.patch \
28 file://0001-hook-Do-not-append-int-to-std-string.patch \
Brad Bishop2d39a062019-10-28 08:33:36 -040029 file://0001-Bug-fix-for-data-type-length-judgment.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050030 file://0001-ensure-the-struct-pointers-are-null-initilized.patch \
Andrew Geissler69721092021-07-23 12:57:00 -040031 file://0001-ppc-Remove-unused-host_powerpc64-function.patch \
32 file://0001-mips-Use-hardcodes-values-for-ABI-syscall-bases.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033 "
Patrick Williams213cb262021-08-07 19:21:33 -050034SRC_URI:append:libc-musl = " file://add_ppc64le.patch"
Andrew Geissler32b11992021-03-31 13:37:05 -050035
Patrick Williamsb48b7b42016-08-17 15:04:38 -050036S = "${WORKDIR}/git"
37
38inherit autotools
39
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
42PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
43
Patrick Williams213cb262021-08-07 19:21:33 -050044COMPATIBLE_HOST:riscv64 = "null"
45COMPATIBLE_HOST:riscv32 = "null"
Andrew Geissler82c905d2020-04-13 13:39:40 -050046
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060048 ( cd ${S}; ./autogen.sh )
Patrick Williamsb48b7b42016-08-17 15:04:38 -050049}