blob: ad770ce2ad9f11625387864ad24e6580047bdee8 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
Patrick Williams213cb262021-08-07 19:21:33 -05005RDEPENDS:${PN} = "libusb1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006
Brad Bishop757e94a2018-09-07 18:58:51 +00007SRC_URI = " \
8 git://repo.or.cz/openocd.git;protocol=http;name=openocd \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
Brad Bishop757e94a2018-09-07 18:58:51 +000014SRCREV_FORMAT = "openocd"
Andrew Geissler32b11992021-03-31 13:37:05 -050015SRCREV_openocd = "f342aac0845a69d591ad39a025d74e9c765f6420"
Brad Bishop757e94a2018-09-07 18:58:51 +000016SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
Andrew Geisslerd688a012020-09-18 13:36:00 -050017SRCREV_jimtcl = "0aa0fb4e3a38d38a49de9eb585d93d63a370dcf6"
18SRCREV_libjaylink = "9aa7a5957c07bb6e862fc1a6d3153d109c7407e4"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
Andrew Geissler32b11992021-03-31 13:37:05 -050020PV = "0.11+gitr${SRCPV}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021S = "${WORKDIR}/git"
22
23inherit pkgconfig autotools-brokensep gettext
24
Brad Bishop2f973922019-11-11 07:58:48 -050025BBCLASSEXTEND += "native nativesdk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026
Brad Bishopa891d152019-09-13 06:17:45 -040027EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror"
28
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029do_configure() {
Brad Bishop757e94a2018-09-07 18:58:51 +000030 ./bootstrap nosubmodule
Brad Bishop19323692019-04-05 15:28:33 -040031 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup
32 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 oe_runconf ${EXTRA_OECONF}
34}
35
36do_install() {
37 oe_runmake DESTDIR=${D} install
38 if [ -e "${D}${infodir}" ]; then
39 rm -Rf ${D}${infodir}
40 fi
41 if [ -e "${D}${mandir}" ]; then
42 rm -Rf ${D}${mandir}
43 fi
44 if [ -e "${D}${bindir}/.debug" ]; then
45 rm -Rf ${D}${bindir}/.debug
46 fi
47}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049FILES:${PN} = " \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050050 ${datadir}/openocd/* \
51 ${bindir}/openocd \
52 "
53
54PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
Brad Bishope42b3e32020-01-15 22:08:42 -050055PACKAGECONFIG[remote-bitbang] = "--enable-remote-bitbang,--disable-remote-bitbang"
56PACKAGECONFIG ??= "sysfsgpio remote-bitbang"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060057
58# Can't be built with ccache
59CCACHE_DISABLE = "1"