blob: c501b1534d0218deb76e9743e3399f9f868ad904 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A graphical front-end for gcov"
2HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php"
3DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
4tool gcov. It collects gcov data for multiple source files and creates \
5HTML pages containing the source code annotated with coverage information. \
6It also adds overview pages for easy navigation within the file structure. \
Patrick Williamsddad1a12017-02-23 20:36:32 -06007LCOV supports statement, function and branch coverage measurement."
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008LICENSE = "GPL-2.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
Patrick Williams213cb262021-08-07 19:21:33 -050011RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 libjson-perl \
13 libperlio-gzip-perl \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014 perl \
15 perl-module-filehandle \
16 perl-module-getopt-std \
Brad Bishop0e2770c2020-01-21 07:31:46 -050017 perl-module-digest-md5 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018 perl-module-digest-sha \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019 perl-module-constant \
20 perl-module-cwd \
21 perl-module-errno \
22 perl-module-file-basename \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 perl-module-file-copy \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024 perl-module-file-find \
25 perl-module-file-path \
26 perl-module-file-spec \
27 perl-module-file-spec-functions \
28 perl-module-file-spec-unix \
29 perl-module-file-temp \
30 perl-module-getopt-long \
31 perl-module-list-util \
32 perl-module-mro \
33 perl-module-overload \
34 perl-module-overloading \
35 perl-module-overload-numbers \
36 perl-module-parent \
37 perl-module-pod-usage \
38 perl-module-posix \
39 perl-module-re \
40 perl-module-safe \
41 perl-module-scalar-util \
42 perl-module-term-cap \
43 perl-module-text-parsewords \
44 perl-module-tie-hash \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050045"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047RDEPENDS:${PN}:append:class-target = " \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050048 gcov \
49 gcov-symlinks \
50"
51
Andrew Geissler82c905d2020-04-13 13:39:40 -050052SRC_URI = " \
53 http://downloads.sourceforge.net/ltp/${BP}.tar.gz \
54 file://0001-geninfo-Add-intermediate-text-format-support.patch \
55 file://0002-geninfo-Add-intermediate-JSON-format-support.patch \
56 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050057
Brad Bishop15ae2502019-06-18 21:44:24 -040058SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
59SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050060
61do_install() {
Brad Bishop15ae2502019-06-18 21:44:24 -040062 oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050063}
64
Andrew Geissler82c905d2020-04-13 13:39:40 -050065BBCLASSEXTEND = "native nativesdk"