blob: 4c0845a0fa0eaa55631a97cea24c0f3cb9bc859f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
12"
Andrew Geissler69721092021-07-23 12:57:00 -040013SRCREV = "ad0030f071b7ce7eb748eca3c31cb381038e2b21"
Brad Bishop19323692019-04-05 15:28:33 -040014S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020 gperf-native \
21 json-c \
22 nettle \
Andrew Geissler8fc454f2020-12-11 16:27:59 -060023 glib-2.0 \
Brad Bishop19323692019-04-05 15:28:33 -040024"
25
Brad Bishop26bdd442019-08-16 17:08:17 -040026PACKAGES += "python3-${BPN}"
Patrick Williams213cb262021-08-07 19:21:33 -050027FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
Brad Bishop19323692019-04-05 15:28:33 -040028
29PACKAGECONFIG ??= "python3 rpm"
Brad Bishop19323692019-04-05 15:28:33 -040030PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
31PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033do_configure:prepend() {
Brad Bishop19323692019-04-05 15:28:33 -040034 ${S}/gen-version
35}