blob: 794e9930ad9a94655e0e831c97a82b5663baf63a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# IceCream distributed compiling support
2#
3# Stages directories with symlinks from gcc/g++ to icecc, for both
4# native and cross compilers. Depending on each configure or compile,
5# the directories are added at the head of the PATH list and ICECC_CXX
6# and ICEC_CC are set.
7#
8# For the cross compiler, creates a tar.gz of our toolchain and sets
9# ICECC_VERSION accordingly.
10#
11# The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the
12# necessary environment tar.gz file to be used by the remote machines.
13# It also supports meta-toolchain generation
14#
15# If ICECC_PATH is not set in local.conf then the class will try to locate it using 'bb.utils.which'
16# but nothing is sure ;)
17#
18# If ICECC_ENV_EXEC is set in local.conf, then it should point to the icecc-create-env script provided by the user
19# or the default one provided by icecc-create-env.bb will be used
20# (NOTE that this is a modified version of the script need it and *not the one that comes with icecc*
21#
22# User can specify if specific packages or packages belonging to class should not use icecc to distribute
23# compile jobs to remote machines, but handled locally, by defining ICECC_USER_CLASS_BL and ICECC_USER_PACKAGE_BL
24# with the appropriate values in local.conf. In addition the user can force to enable icecc for packages
25# which set an empty PARALLEL_MAKE variable by defining ICECC_USER_PACKAGE_WL.
26#
27#########################################################################################
28#Error checking is kept to minimum so double check any parameters you pass to the class
29###########################################################################################
30
Brad Bishop316dfdd2018-06-25 12:45:53 -040031BB_HASHBASE_WHITELIST += "ICECC_PARALLEL_MAKE ICECC_DISABLED ICECC_USER_PACKAGE_BL \
32 ICECC_USER_CLASS_BL ICECC_USER_PACKAGE_WL ICECC_PATH ICECC_ENV_EXEC \
33 ICECC_CARET_WORKAROUND ICECC_CFLAGS ICECC_ENV_VERSION \
34 ICECC_DEBUG ICECC_LOGFILE ICECC_REPEAT_RATE ICECC_PREFERRED_HOST \
35 ICECC_CLANG_REMOTE_CPP ICECC_IGNORE_UNVERIFIED ICECC_TEST_SOCKET \
Brad Bishopa5c52ff2018-11-23 10:55:50 +130036 ICECC_ENV_DEBUG ICECC_SYSTEM_PACKAGE_BL ICECC_SYSTEM_CLASS_BL \
Brad Bishop19323692019-04-05 15:28:33 -040037 ICECC_REMOTE_CPP \
Brad Bishop316dfdd2018-06-25 12:45:53 -040038 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
40ICECC_ENV_EXEC ?= "${STAGING_BINDIR_NATIVE}/icecc-create-env"
41
Brad Bishop977dc1a2019-02-06 16:01:43 -050042HOSTTOOLS_NONFATAL += "icecc patchelf"
43
Brad Bishop316dfdd2018-06-25 12:45:53 -040044# This version can be incremented when changes are made to the environment that
45# invalidate the version on the compile nodes. Changing it will cause a new
46# environment to be created.
47#
48# A useful thing to do for testing Icecream changes locally is to add a
49# subversion in local.conf:
Patrick Williams213cb262021-08-07 19:21:33 -050050# ICECC_ENV_VERSION:append = "-my-ver-1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040051ICECC_ENV_VERSION = "2"
52
53# Default to disabling the caret workaround, If set to "1" in local.conf, icecc
54# will locally recompile any files that have warnings, which can adversely
55# affect performance.
56#
57# See: https://github.com/icecc/icecream/issues/190
58export ICECC_CARET_WORKAROUND ??= "0"
59
Brad Bishop96ff1982019-08-19 13:50:42 -040060export ICECC_REMOTE_CPP ??= "0"
Brad Bishop19323692019-04-05 15:28:33 -040061
Brad Bishop316dfdd2018-06-25 12:45:53 -040062ICECC_CFLAGS = ""
63CFLAGS += "${ICECC_CFLAGS}"
64CXXFLAGS += "${ICECC_CFLAGS}"
65
66# Debug flags when generating environments
67ICECC_ENV_DEBUG ??= ""
68
Brad Bishopa5c52ff2018-11-23 10:55:50 +130069# "system" recipe blacklist contains a list of packages that can not distribute
70# compile tasks for one reason or the other. When adding new entry, please
71# document why (how it failed) so that we can re-evaluate it later e.g. when
72# there is new version
73#
74# libgcc-initial - fails with CPP sanity check error if host sysroot contains
75# cross gcc built for another target tune/variant
Brad Bishopa34c0302019-09-23 22:34:48 -040076# pixman - prng_state: TLS reference mismatches non-TLS reference, possibly due to
77# pragma omp threadprivate(prng_state)
Brad Bishop79641f22019-09-10 07:20:22 -040078# systemtap - _HelperSDT.c undefs macros and uses the identifiers in macros emitting
79# inline assembly
Brad Bishopa5c52ff2018-11-23 10:55:50 +130080# target-sdk-provides-dummy - ${HOST_PREFIX} is empty which triggers the "NULL
81# prefix" error.
82ICECC_SYSTEM_PACKAGE_BL += "\
83 libgcc-initial \
Brad Bishopa34c0302019-09-23 22:34:48 -040084 pixman \
Brad Bishop79641f22019-09-10 07:20:22 -040085 systemtap \
Brad Bishopa5c52ff2018-11-23 10:55:50 +130086 target-sdk-provides-dummy \
87 "
88
89# "system" classes that should be blacklisted. When adding new entry, please
90# document why (how it failed) so that we can re-evaluate it later
91#
92# image - Image aren't compiling, but the testing framework for images captures
93# PARALLEL_MAKE as part of the test environment. Many tests won't use
94# icecream, but leaving the high level of parallelism can cause them to
95# consume an unnecessary amount of resources.
96ICECC_SYSTEM_CLASS_BL += "\
97 image \
98 "
99
Patrick Williams213cb262021-08-07 19:21:33 -0500100def get_icecc_dep(d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500101 # INHIBIT_DEFAULT_DEPS doesn't apply to the patch command. Whether or not
102 # we need that built is the responsibility of the patch function / class, not
103 # the application.
Brad Bishop316dfdd2018-06-25 12:45:53 -0400104 if not d.getVar('INHIBIT_DEFAULT_DEPS'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500105 return "icecc-create-env-native"
106 return ""
107
Patrick Williams213cb262021-08-07 19:21:33 -0500108DEPENDS:prepend = "${@get_icecc_dep(d)} "
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500109
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500110get_cross_kernel_cc[vardepsexclude] += "KERNEL_CC"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500111def get_cross_kernel_cc(bb,d):
Brad Bishop977dc1a2019-02-06 16:01:43 -0500112 if not icecc_is_kernel(bb, d):
113 return None
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500114
115 # evaluate the expression by the shell if necessary
Brad Bishop977dc1a2019-02-06 16:01:43 -0500116 kernel_cc = d.getVar('KERNEL_CC')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500117 if '`' in kernel_cc or '$(' in kernel_cc:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600118 import subprocess
119 kernel_cc = subprocess.check_output("echo %s" % kernel_cc, shell=True).decode("utf-8")[:-1]
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500120
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500121 kernel_cc = kernel_cc.replace('ccache', '').strip()
122 kernel_cc = kernel_cc.split(' ')[0]
123 kernel_cc = kernel_cc.strip()
124 return kernel_cc
125
126def get_icecc(d):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400127 return d.getVar('ICECC_PATH') or bb.utils.which(os.getenv("PATH"), "icecc")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500129def use_icecc(bb,d):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400130 if d.getVar('ICECC_DISABLED') == "1":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131 # don't even try it, when explicitly disabled
132 return "no"
133
134 # allarch recipes don't use compiler
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500135 if icecc_is_allarch(bb, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500136 return "no"
137
Brad Bishop316dfdd2018-06-25 12:45:53 -0400138 if icecc_is_cross_canadian(bb, d):
139 return "no"
140
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500141 pn = d.getVar('PN')
Brad Bishop19323692019-04-05 15:28:33 -0400142 bpn = d.getVar('BPN')
143
144 # Blacklist/whitelist checks are made against BPN, because there is a good
145 # chance that if icecc should be skipped for a recipe, it should be skipped
146 # for all the variants of that recipe. PN is still checked in case a user
147 # specified a more specific recipe.
148 check_pn = set([pn, bpn])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500149
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300150 system_class_blacklist = (d.getVar('ICECC_SYSTEM_CLASS_BL') or "").split()
Brad Bishop316dfdd2018-06-25 12:45:53 -0400151 user_class_blacklist = (d.getVar('ICECC_USER_CLASS_BL') or "none").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500152 package_class_blacklist = system_class_blacklist + user_class_blacklist
153
154 for black in package_class_blacklist:
155 if bb.data.inherits_class(black, d):
156 bb.debug(1, "%s: class %s found in blacklist, disable icecc" % (pn, black))
157 return "no"
158
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300159 system_package_blacklist = (d.getVar('ICECC_SYSTEM_PACKAGE_BL') or "").split()
Brad Bishop316dfdd2018-06-25 12:45:53 -0400160 user_package_blacklist = (d.getVar('ICECC_USER_PACKAGE_BL') or "").split()
161 user_package_whitelist = (d.getVar('ICECC_USER_PACKAGE_WL') or "").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500162 package_blacklist = system_package_blacklist + user_package_blacklist
163
Brad Bishop19323692019-04-05 15:28:33 -0400164 if check_pn & set(package_blacklist):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500165 bb.debug(1, "%s: found in blacklist, disable icecc" % pn)
166 return "no"
167
Brad Bishop19323692019-04-05 15:28:33 -0400168 if check_pn & set(user_package_whitelist):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500169 bb.debug(1, "%s: found in whitelist, enable icecc" % pn)
170 return "yes"
171
Brad Bishop316dfdd2018-06-25 12:45:53 -0400172 if d.getVar('PARALLEL_MAKE') == "":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500173 bb.debug(1, "%s: has empty PARALLEL_MAKE, disable icecc" % pn)
174 return "no"
175
176 return "yes"
177
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500178def icecc_is_allarch(bb, d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800179 return d.getVar("PACKAGE_ARCH") == "all"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500180
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500181def icecc_is_kernel(bb, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500182 return \
183 bb.data.inherits_class("kernel", d);
184
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500185def icecc_is_native(bb, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186 return \
187 bb.data.inherits_class("cross", d) or \
188 bb.data.inherits_class("native", d);
189
Brad Bishop316dfdd2018-06-25 12:45:53 -0400190def icecc_is_cross_canadian(bb, d):
191 return bb.data.inherits_class("cross-canadian", d)
192
193def icecc_dir(bb, d):
194 return d.expand('${TMPDIR}/work-shared/ice')
195
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500196# Don't pollute allarch signatures with TARGET_FPU
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500197icecc_version[vardepsexclude] += "TARGET_FPU"
198def icecc_version(bb, d):
199 if use_icecc(bb, d) == "no":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500200 return ""
201
Brad Bishop316dfdd2018-06-25 12:45:53 -0400202 parallel = d.getVar('ICECC_PARALLEL_MAKE') or ""
203 if not d.getVar('PARALLEL_MAKE') == "" and parallel:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500204 d.setVar("PARALLEL_MAKE", parallel)
205
Brad Bishop316dfdd2018-06-25 12:45:53 -0400206 # Disable showing the caret in the GCC compiler output if the workaround is
207 # disabled
208 if d.getVar('ICECC_CARET_WORKAROUND') == '0':
209 d.setVar('ICECC_CFLAGS', '-fno-diagnostics-show-caret')
210
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500211 if icecc_is_native(bb, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500212 archive_name = "local-host-env"
213 elif d.expand('${HOST_PREFIX}') == "":
214 bb.fatal(d.expand("${PN}"), " NULL prefix")
215 else:
216 prefix = d.expand('${HOST_PREFIX}' )
217 distro = d.expand('${DISTRO}')
218 target_sys = d.expand('${TARGET_SYS}')
Brad Bishop316dfdd2018-06-25 12:45:53 -0400219 float = d.getVar('TARGET_FPU') or "hard"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500220 archive_name = prefix + distro + "-" + target_sys + "-" + float
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500221 if icecc_is_kernel(bb, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500222 archive_name += "-kernel"
223
224 import socket
Brad Bishop316dfdd2018-06-25 12:45:53 -0400225 ice_dir = icecc_dir(bb, d)
226 tar_file = os.path.join(ice_dir, "{archive}-{version}-@VERSION@-{hostname}.tar.gz".format(
227 archive=archive_name,
228 version=d.getVar('ICECC_ENV_VERSION'),
229 hostname=socket.gethostname()
230 ))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500231
232 return tar_file
233
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500234def icecc_path(bb,d):
235 if use_icecc(bb, d) == "no":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500236 # don't create unnecessary directories when icecc is disabled
237 return
238
Brad Bishop977dc1a2019-02-06 16:01:43 -0500239 staging = os.path.join(d.expand('${STAGING_BINDIR}'), "ice")
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500240 if icecc_is_kernel(bb, d):
Brad Bishop977dc1a2019-02-06 16:01:43 -0500241 staging += "-kernel"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500242
Brad Bishop977dc1a2019-02-06 16:01:43 -0500243 return staging
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500244
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500245def icecc_get_external_tool(bb, d, tool):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500246 external_toolchain_bindir = d.expand('${EXTERNAL_TOOLCHAIN}${bindir_cross}')
247 target_prefix = d.expand('${TARGET_PREFIX}')
248 return os.path.join(external_toolchain_bindir, '%s%s' % (target_prefix, tool))
249
Brad Bishop316dfdd2018-06-25 12:45:53 -0400250def icecc_get_tool_link(tool, d):
251 import subprocess
Brad Bishop08902b02019-08-20 09:16:51 -0400252 try:
253 return subprocess.check_output("readlink -f %s" % tool, shell=True).decode("utf-8")[:-1]
254 except subprocess.CalledProcessError as e:
255 bb.note("icecc: one of the tools probably disappeared during recipe parsing, cmd readlink -f %s returned %d:\n%s" % (tool, e.returncode, e.output.decode("utf-8")))
256 return tool
Brad Bishop316dfdd2018-06-25 12:45:53 -0400257
258def icecc_get_path_tool(tool, d):
259 # This is a little ugly, but we want to make sure we add an actual
260 # compiler to the toolchain, not ccache. Some distros (e.g. Fedora)
261 # have ccache enabled by default using symlinks PATH, meaning ccache
262 # would be found first when looking for the compiler.
263 paths = os.getenv("PATH").split(':')
264 while True:
265 p, hist = bb.utils.which(':'.join(paths), tool, history=True)
266 if not p or os.path.basename(icecc_get_tool_link(p, d)) != 'ccache':
267 return p
268 paths = paths[len(hist):]
269
270 return ""
271
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500272# Don't pollute native signatures with target TUNE_PKGARCH through STAGING_BINDIR_TOOLCHAIN
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500273icecc_get_tool[vardepsexclude] += "STAGING_BINDIR_TOOLCHAIN"
274def icecc_get_tool(bb, d, tool):
275 if icecc_is_native(bb, d):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400276 return icecc_get_path_tool(tool, d)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500277 elif icecc_is_kernel(bb, d):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400278 return icecc_get_path_tool(get_cross_kernel_cc(bb, d), d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500279 else:
280 ice_dir = d.expand('${STAGING_BINDIR_TOOLCHAIN}')
281 target_sys = d.expand('${TARGET_SYS}')
Brad Bishop316dfdd2018-06-25 12:45:53 -0400282 for p in ice_dir.split(':'):
283 tool_bin = os.path.join(p, "%s-%s" % (target_sys, tool))
284 if os.path.isfile(tool_bin):
285 return tool_bin
286 external_tool_bin = icecc_get_external_tool(bb, d, tool)
287 if os.path.isfile(external_tool_bin):
288 return external_tool_bin
289 return ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500290
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500291def icecc_get_and_check_tool(bb, d, tool):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500292 # Check that g++ or gcc is not a symbolic link to icecc binary in
293 # PATH or icecc-create-env script will silently create an invalid
294 # compiler environment package.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500295 t = icecc_get_tool(bb, d, tool)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600296 if t:
Brad Bishop977dc1a2019-02-06 16:01:43 -0500297 link_path = icecc_get_tool_link(t, d)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600298 if link_path == get_icecc(d):
Brad Bishop977dc1a2019-02-06 16:01:43 -0500299 bb.error("%s is a symlink to %s in PATH and this prevents icecc from working" % (t, link_path))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600300 return ""
301 else:
302 return t
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500303 else:
304 return t
305
306wait_for_file() {
307 local TIME_ELAPSED=0
308 local FILE_TO_TEST=$1
309 local TIMEOUT=$2
310 until [ -f "$FILE_TO_TEST" ]
311 do
312 TIME_ELAPSED=`expr $TIME_ELAPSED + 1`
313 if [ $TIME_ELAPSED -gt $TIMEOUT ]
314 then
315 return 1
316 fi
317 sleep 1
318 done
319}
320
321def set_icecc_env():
322 # dummy python version of set_icecc_env
323 return
324
Brad Bishopc342db32019-05-15 21:57:59 -0400325set_icecc_env[vardepsexclude] += "KERNEL_CC"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500326set_icecc_env() {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500327 if [ "${@use_icecc(bb, d)}" = "no" ]
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500328 then
329 return
330 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500331 ICECC_VERSION="${@icecc_version(bb, d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500332 if [ "x${ICECC_VERSION}" = "x" ]
333 then
334 bbwarn "Cannot use icecc: could not get ICECC_VERSION"
335 return
336 fi
337
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500338 ICE_PATH="${@icecc_path(bb, d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500339 if [ "x${ICE_PATH}" = "x" ]
340 then
341 bbwarn "Cannot use icecc: could not get ICE_PATH"
342 return
343 fi
344
Brad Bishop977dc1a2019-02-06 16:01:43 -0500345 ICECC_BIN="${@get_icecc(d)}"
346 if [ -z "${ICECC_BIN}" ]; then
347 bbwarn "Cannot use icecc: icecc binary not found"
348 return
349 fi
350 if [ -z "$(which patchelf patchelf-uninative)" ]; then
351 bbwarn "Cannot use icecc: patchelf not found"
352 return
353 fi
354
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500355 ICECC_CC="${@icecc_get_and_check_tool(bb, d, "gcc")}"
356 ICECC_CXX="${@icecc_get_and_check_tool(bb, d, "g++")}"
357 # cannot use icecc_get_and_check_tool here because it assumes as without target_sys prefix
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500358 ICECC_WHICH_AS="${@bb.utils.which(os.getenv('PATH'), 'as')}"
359 if [ ! -x "${ICECC_CC}" -o ! -x "${ICECC_CXX}" ]
360 then
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700361 bbnote "Cannot use icecc: could not get ICECC_CC or ICECC_CXX"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500362 return
363 fi
364
365 ICE_VERSION=`$ICECC_CC -dumpversion`
366 ICECC_VERSION=`echo ${ICECC_VERSION} | sed -e "s/@VERSION@/$ICE_VERSION/g"`
367 if [ ! -x "${ICECC_ENV_EXEC}" ]
368 then
369 bbwarn "Cannot use icecc: invalid ICECC_ENV_EXEC"
370 return
371 fi
372
Brad Bishop64c979e2019-11-04 13:55:29 -0500373 # Create symlinks to icecc and wrapper-scripts in the recipe-sysroot directory
374 mkdir -p $ICE_PATH/symlinks
375 if [ -n "${KERNEL_CC}" ]; then
376 compilers="${@get_cross_kernel_cc(bb,d)}"
377 else
378 compilers="${HOST_PREFIX}gcc ${HOST_PREFIX}g++"
379 fi
380 for compiler in $compilers; do
381 ln -sf $ICECC_BIN $ICE_PATH/symlinks/$compiler
382 rm -f $ICE_PATH/$compiler
383 cat <<-__EOF__ > $ICE_PATH/$compiler
384 #!/bin/sh -e
385 export ICECC_VERSION=$ICECC_VERSION
386 export ICECC_CC=$ICECC_CC
387 export ICECC_CXX=$ICECC_CXX
388 $ICE_PATH/symlinks/$compiler "\$@"
389 __EOF__
390 chmod 775 $ICE_PATH/$compiler
391 done
392
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500393 ICECC_AS="`${ICECC_CC} -print-prog-name=as`"
394 # for target recipes should return something like:
395 # /OE/tmp-eglibc/sysroots/x86_64-linux/usr/libexec/arm920tt-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.8.2/as
396 # and just "as" for native, if it returns "as" in current directory (for whatever reason) use "as" from PATH
397 if [ "`dirname "${ICECC_AS}"`" = "." ]
398 then
399 ICECC_AS="${ICECC_WHICH_AS}"
400 fi
401
402 if [ ! -f "${ICECC_VERSION}.done" ]
403 then
404 mkdir -p "`dirname "${ICECC_VERSION}"`"
405
406 # the ICECC_VERSION generation step must be locked by a mutex
407 # in order to prevent race conditions
408 if flock -n "${ICECC_VERSION}.lock" \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400409 ${ICECC_ENV_EXEC} ${ICECC_ENV_DEBUG} "${ICECC_CC}" "${ICECC_CXX}" "${ICECC_AS}" "${ICECC_VERSION}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500410 then
411 touch "${ICECC_VERSION}.done"
Brad Bishop19323692019-04-05 15:28:33 -0400412 elif ! wait_for_file "${ICECC_VERSION}.done" 30
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500413 then
414 # locking failed so wait for ${ICECC_VERSION}.done to appear
415 bbwarn "Timeout waiting for ${ICECC_VERSION}.done"
416 return
417 fi
418 fi
419
Brad Bishop316dfdd2018-06-25 12:45:53 -0400420 # Don't let ccache find the icecream compiler links that have been created, otherwise
421 # it can end up invoking icecream recursively.
422 export CCACHE_PATH="$PATH"
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300423 export CCACHE_DISABLE="1"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400424
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500425 export PATH="$ICE_PATH:$PATH"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500426
Brad Bishop19323692019-04-05 15:28:33 -0400427 bbnote "Using icecc path: $ICE_PATH"
428 bbnote "Using icecc tarball: $ICECC_VERSION"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500429}
430
Patrick Williams213cb262021-08-07 19:21:33 -0500431do_configure:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500432 set_icecc_env
433}
434
Patrick Williams213cb262021-08-07 19:21:33 -0500435do_compile:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500436 set_icecc_env
437}
438
Patrick Williams213cb262021-08-07 19:21:33 -0500439do_compile_kernelmodules:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500440 set_icecc_env
441}
442
Patrick Williams213cb262021-08-07 19:21:33 -0500443do_install:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500444 set_icecc_env
445}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400446
447# IceCream is not (currently) supported in the extensible SDK
448ICECC_SDK_HOST_TASK = "nativesdk-icecc-toolchain"
Patrick Williams213cb262021-08-07 19:21:33 -0500449ICECC_SDK_HOST_TASK:task-populate-sdk-ext = ""
Brad Bishop316dfdd2018-06-25 12:45:53 -0400450
451# Don't include IceCream in uninative tarball
Patrick Williams213cb262021-08-07 19:21:33 -0500452ICECC_SDK_HOST_TASK:pn-uninative-tarball = ""
Brad Bishop316dfdd2018-06-25 12:45:53 -0400453
454# Add the toolchain scripts to the SDK
Patrick Williams213cb262021-08-07 19:21:33 -0500455TOOLCHAIN_HOST_TASK:append = " ${ICECC_SDK_HOST_TASK}"