blob: 29fc49fb3922f5d2917564fd1f7396c2b8952ea0 [file] [log] [blame]
Andrew Geissler4ed12e12020-06-05 18:00:41 -05001SUMMARY = "Advanced front-end for dpkg"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "APT is the Advanced Package Tool, an advanced interface to the Debian packaging system which provides the apt-get program."
3HOMEPAGE = "https://packages.debian.org/jessie/apt"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05004LICENSE = "GPLv2.0+"
5SECTION = "base"
6
7# Triehash script taken from https://github.com/julian-klode/triehash
8SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/${BPN}_${PV}.tar.xz \
9 file://triehash \
10 file://0001-Disable-documentation-directory-altogether.patch \
11 file://0001-Fix-musl-build.patch \
12 file://0001-CMakeLists.txt-avoid-changing-install-paths-based-on.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050013 file://0001-srvrec-Keep-support-for-older-resolver.patch \
14 file://0001-cmake-Do-not-build-po-files.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050015 file://0001-Hide-fstatat64-and-prlimit64-defines-on-musl.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070016 file://0001-aptwebserver.cc-Include-array.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050017 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019SRC_URI:append:class-native = " \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050020 file://0001-Do-not-init-tables-from-dpkg-configuration.patch \
21 file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050022 "
23
Patrick Williams213cb262021-08-07 19:21:33 -050024SRC_URI:append:class-nativesdk = " \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060025 file://0001-Do-not-init-tables-from-dpkg-configuration.patch \
26 file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060027 "
28
Andrew Geissler09036742021-06-25 14:25:14 -050029SRC_URI[sha256sum] = "6eecd04a4979bd2040b22a14571c15d342c4e1802b2023acb5aa19649b1f64ea"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050030LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263"
31
32# the package is taken from snapshots.debian.org; that source is static and goes stale
33# so we check the latest upstream from a directory that does get updated
34UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/apt/"
35
Andrew Geisslerd1e89492021-02-12 15:35:20 -060036inherit cmake perlnative bash-completion upstream-version-is-even useradd
Andrew Geissler4ed12e12020-06-05 18:00:41 -050037
Andrew Geisslerd1e89492021-02-12 15:35:20 -060038# User is added to allow apt to drop privs, will runtime warn without
39USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050040USERADD_PARAM:${PN} = "--system --home /nonexistent --no-create-home _apt"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060041
42BBCLASSEXTEND = "native nativesdk"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050043
Andrew Geissler95ac1b82021-03-31 14:34:31 -050044DEPENDS += "db gnutls lz4 zlib bzip2 xz libgcrypt xxhash"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050045
Patrick Williams213cb262021-08-07 19:21:33 -050046EXTRA_OECMAKE:append = " -DCURRENT_VENDOR=debian -DWITH_DOC=False \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050047 -DDPKG_DATADIR=${datadir}/dpkg \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060048 -DTRIEHASH_EXECUTABLE=${WORKDIR}/triehash \
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050049 -DCMAKE_DISABLE_FIND_PACKAGE_ZSTD=True \
Andrew Geisslerc926e172021-05-07 16:11:35 -050050 -DCMAKE_DISABLE_FIND_PACKAGE_SECCOMP=True \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050051 -DWITH_TESTS=False \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060052"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050053
Patrick Williams213cb262021-08-07 19:21:33 -050054do_configure:prepend () {
Andrew Geissler4ed12e12020-06-05 18:00:41 -050055 echo "set( CMAKE_FIND_ROOT_PATH_MODE_INCLUDE BOTH )" >> ${WORKDIR}/toolchain.cmake
56
57}
58
59# Unfortunately apt hardcodes this all over the place
Patrick Williams213cb262021-08-07 19:21:33 -050060FILES:${PN} += "${prefix}/lib/dpkg ${prefix}/lib/apt"
61RDEPENDS:${PN} += "bash perl dpkg"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050062
Andrew Geisslerd1e89492021-02-12 15:35:20 -060063customize_apt_conf_sample() {
Andrew Geissler4ed12e12020-06-05 18:00:41 -050064 cat > ${D}${sysconfdir}/apt/apt.conf.sample << EOF
65Dir "${STAGING_DIR_NATIVE}/"
66{
67 State "var/lib/apt/"
68 {
69 Lists "#APTCONF#/lists/";
70 status "#ROOTFS#/var/lib/dpkg/status";
71 };
72 Cache "var/cache/apt/"
73 {
74 Archives "archives/";
75 pkgcache "";
76 srcpkgcache "";
77 };
78 Bin "${STAGING_BINDIR_NATIVE}/"
79 {
80 methods "${STAGING_LIBDIR}/apt/methods/";
81 gzip "/bin/gzip";
82 dpkg "dpkg";
83 dpkg-source "dpkg-source";
84 dpkg-buildpackage "dpkg-buildpackage";
85 apt-get "apt-get";
86 apt-cache "apt-cache";
87 };
88 Etc "#APTCONF#"
89 {
90 Preferences "preferences";
91 };
92 Log "var/log/apt";
93};
94
95APT
96{
97 Install-Recommends "true";
98 Immediate-Configure "false";
99 Architecture "i586";
100 Get
101 {
102 Assume-Yes "true";
103 };
104};
105
106Acquire
107{
108 AllowInsecureRepositories "true";
109};
110
111DPkg::Options {"--root=#ROOTFS#";"--admindir=#ROOTFS#/var/lib/dpkg";"--force-all";"--no-debsig"};
112DPkg::Path "";
113EOF
114}
115
Patrick Williams213cb262021-08-07 19:21:33 -0500116do_install:append:class-native() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600117 customize_apt_conf_sample
118}
119
Patrick Williams213cb262021-08-07 19:21:33 -0500120do_install:append:class-nativesdk() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600121 customize_apt_conf_sample
122}
123
124
Patrick Williams213cb262021-08-07 19:21:33 -0500125do_install:append:class-target() {
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500126 #Write the correct apt-architecture to apt.conf
127 APT_CONF=${D}/etc/apt/apt.conf
128 echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
129}
130
131# Avoid non-reproducible -src package
Patrick Williams213cb262021-08-07 19:21:33 -0500132do_install:append () {
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500133 sed -i -e "s,${B},,g" \
134 ${B}/apt-pkg/tagfile-keys.cc
135}