blob: 56f5b742e29a3deb8bce0db5a9ea9b210c8809c1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
William A. Kennington IIIac69b482021-06-02 12:28:27 -07006LICENSE = "BSD-3-Clause & LGPL-2.0+"
Patrick Williams213cb262021-08-07 19:21:33 -05007LICENSE:${PN}-libfl = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
10BBCLASSEXTEND = "native nativesdk"
11
William A. Kennington IIIac69b482021-06-02 12:28:27 -070012LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067 \
13 file://src/gettext.h;beginline=1;endline=17;md5=9c05dda2f58d89b850c399cf22e1a00c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
16 file://run-ptest \
17 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
18 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
19 file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050020 file://check-funcs.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060021 file://0001-Emit-no-line-directives-if-gen_line_dirs-is-false.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 "
23
24SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
25SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
26
27# Flex has moved to github from 2.6.1 onwards
28UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
29UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
30
31inherit autotools gettext texinfo ptest
32
33M4 = "${bindir}/m4"
Patrick Williams213cb262021-08-07 19:21:33 -050034M4:class-native = "${STAGING_BINDIR_NATIVE}/m4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
36EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
37
38EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040do_install:append:class-native() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 create_wrapper ${D}/${bindir}/flex M4=${M4}
42}
43
Patrick Williams213cb262021-08-07 19:21:33 -050044do_install:append:class-nativesdk() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 create_wrapper ${D}/${bindir}/flex M4=${M4}
46}
47
48PACKAGES =+ "${PN}-libfl"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050FILES:${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051
Patrick Williams213cb262021-08-07 19:21:33 -050052RDEPENDS:${PN} += "m4"
53RDEPENDS:${PN}-ptest += "bash gawk make"
Andrew Geissler82c905d2020-04-13 13:39:40 -050054
55do_compile_ptest() {
56 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
57}
58
59do_install_ptest() {
60 mkdir -p ${D}${PTEST_PATH}/build-aux/
61 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
62 cp -r ${S}/tests/* ${D}${PTEST_PATH}
63 cp -r ${B}/tests/* ${D}${PTEST_PATH}
64 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
65 -e 's|${DEBUG_PREFIX_MAP}||g' \
66 -e 's:${HOSTTOOLS_DIR}/::g' \
67 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
68 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
69 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
70 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
71 -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
72 -i ${D}${PTEST_PATH}/Makefile
73}
74# The uninative loader is different on i386 & x86_64 hosts. Since it is only
75# being replaced with /bin/false anyway, it doesn't need to be part of the task
76# hash
77do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
78
79# Not Apache Flex, or Adobe Flex, or IBM Flex.
80CVE_PRODUCT = "flex_project:flex"