blob: e297586bbb80ff145a36ade14f752c84774792e9 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Helper utilities needed by the runqemu script"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00002LICENSE = "GPL-2.0-only"
Patrick Williams213cb262021-08-07 19:21:33 -05003RDEPENDS:${PN} = "qemu-system-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004PR = "r1"
5
6LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008SRC_URI = "\
9 file://tunctl.c \
Patrick Williams2390b1b2022-11-03 13:47:49 -050010 file://qemu-oe-bridge-helper.c \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
13S = "${WORKDIR}"
14
15inherit native
16
17do_compile() {
Brad Bishop64c979e2019-11-04 13:55:29 -050018 ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
Patrick Williams2390b1b2022-11-03 13:47:49 -050019 ${CC} ${CFLAGS} ${LDFLAGS} -Wall qemu-oe-bridge-helper.c -o qemu-oe-bridge-helper
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020}
21
22do_install() {
23 install -d ${D}${bindir}
24 install tunctl ${D}${bindir}/
Patrick Williams2390b1b2022-11-03 13:47:49 -050025 install qemu-oe-bridge-helper ${D}${bindir}/
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027
Brad Bishop19323692019-04-05 15:28:33 -040028DEPENDS += "qemu-system-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029addtask addto_recipe_sysroot after do_populate_sysroot before do_build