blob: 16dbc58dc9dce25040c35c62be9c40725eed188d [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using python.
2
3inherit allarch
4inherit obmc-phosphor-systemd
Brad Bishop93fb5352015-09-09 03:59:20 +00005
6RDEPENDS_${PN} += "python-dbus python-pygobject"
Brad Bishop51607d22015-10-18 22:00:15 -04007INSTALL_NAME ?= "${PN}"
8SCRIPT_NAME ?= "${INSTALL_NAME}.py"
Brad Bishop93fb5352015-09-09 03:59:20 +00009
10do_install_append() {
11 # install the script
12 install -d ${D}${sbindir}
Brad Bishop51607d22015-10-18 22:00:15 -040013 install -m 0755 ${S}/${SCRIPT_NAME} ${D}${sbindir}/${INSTALL_NAME}
Brad Bishop93fb5352015-09-09 03:59:20 +000014}