blob: 502bc4688b0209113843675f9c528690636a12ef [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://github.com/rpm-software-management/libcomps"
3DESCRIPTION = "Libcomps is alternative for yum.comps library. It's written in pure C as library and there's bindings for python2 and python3."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
Brad Bishop19323692019-04-05 15:28:33 -04008 file://0001-Add-crc32.c-to-sources-list.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -05009 file://0002-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 "
11
Andrew Geissler09036742021-06-25 14:25:14 -050012SRCREV = "dfaffdce1969042bda4a184865861573bb07a5a3"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
14S = "${WORKDIR}/git"
15
16inherit cmake distutils3-base
17
18DEPENDS += "libxml2 expat libcheck"
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
21OECMAKE_SOURCEPATH = "${S}/libcomps"
22
23BBCLASSEXTEND = "native nativesdk"
24