blob: 15a8e51550aab5a2acd80957a1e907e01f3e2cd5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
Brad Bishop220d5532018-08-14 00:59:39 +01005HOMEPAGE = "https://sourceware.org/bzip2/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006SECTION = "console/utils"
7LICENSE = "bzip2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=39406315f540c69bd05b1531daedd2ae"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009PR = "r5"
10
Brad Bishop220d5532018-08-14 00:59:39 +010011SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/${BP}.tar.gz \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050012 file://fix-bunzip2-qt-returns-0-for-corrupt-archives.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://configure.ac;subdir=${BP} \
14 file://Makefile.am;subdir=${BP} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015 file://run-ptest \
16 file://CVE-2016-3189.patch \
17 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
20SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd"
21
Brad Bishop220d5532018-08-14 00:59:39 +010022UPSTREAM_CHECK_URI = "https://www.sourceware.org/bzip2/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025PACKAGES =+ "libbz2"
26
27CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
28
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029inherit autotools update-alternatives ptest relative_symlinks
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
31ALTERNATIVE_PRIORITY = "100"
Brad Bishop19323692019-04-05 15:28:33 -040032ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033
34#install binaries to bzip2-native under sysroot for replacement-native
35EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
36
37do_install_ptest () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
39}
40
41FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
42
Brad Bishop393846f2019-05-20 12:24:11 -040043RDEPENDS_${PN}-ptest += "make"
44
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045PROVIDES_append_class-native = " bzip2-replacement-native"
46BBCLASSEXTEND = "native nativesdk"
47