blob: cdf33dcb8664c826bdead5585618578cfc1bc44f [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname"
Andrew Geissler0c3e5ee2021-12-17 19:30:02 +00002OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06003
Patrick Williamsc0201c92022-04-18 14:29:31 -05004IMAGE_FEATURES:append = " obmc-dbus-monitor"
5
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06006# remove so things fit in available flash space
Adriana Kobylakb96c7502021-08-06 16:25:30 +00007IMAGE_FEATURES:remove:witherspoon = "obmc-user-mgmt-ldap"
Andrew Geissler3475f832021-08-12 09:09:41 -04008IMAGE_FEATURES:remove:witherspoon = "obmc-telemetry"
Joseph Reynolds68e567f2021-02-24 17:20:01 -06009
Priyanga Ramasamy3b64b4e2022-11-18 15:32:37 +000010# Remove unused rsyslog service in P10BMC
11IMAGE_FEATURES:remove:p10bmc = "obmc-remote-logging-mgmt"
12
Andrew Geissler0f80cda2021-08-31 15:50:20 -050013# Generic IPMI FRU vpd collection not needed on p10bmc
14IMAGE_FEATURES:remove:p10bmc = "obmc-fru-ipmi"
15
Joseph Reynolds68e567f2021-02-24 17:20:01 -060016# Optionally configure IBM service accounts
17#
18# To configure your distro, add the following line to its config:
19# DISTRO_FEATURES += "ibm-service-account-policy"
20#
21# The service account policy is as follows:
22# root - The root account remains present. It is needed for internal
23# accounting purposes and for debugging service access.
24# admin - Provides administrative control over the BMC. The role is
25# SystemAdministrator. Admin users have access to interfaces including:
26# Redfish, REST APIs, Web. No access to the BMC via: the BMC's physical
27# console, SSH to the BMC's command line.
28# IPMI access is not granted by default, but admins can authorize
29# themselves and enable the IPMI service.
30# The admin has access to the host console: ssh -p2200 admin@${bmc}.
31# The admin account does not have a home directory.
32# service - Provides IBM service and support representatives (SSRs, formerly
33# known as customer engineers or CEs) access to the BMC. The role is
34# OemIBMServiceAgent. The service user has full admin access, plus access
35# to BMC interfaces intended only to service the BMC and host, including
36# SSH access to the BMC's command line.
37# The service account is not authorized to IPMI because of the inherent
38# security weakness in the IPMI spec and also because the IPMI
39# implementation was not enhanced to use the ACF support.
40# The service account does not have a home directory. The home directory is
41# set to / (the root directory) to allow dropbear ssh connections.
42
Joseph Reynolds516363e2021-08-04 10:01:42 -050043# Override defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc
Joseph Reynolds68e567f2021-02-24 17:20:01 -060044
Joseph Reynolds68e567f2021-02-24 17:20:01 -060045#IBM_EXTRA_USERS_PARAMS += " \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050046# usermod -p ${DEFAULT_OPENBMC_PASSWORD} root; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060047# "
48
49# Add group "wheel" (before adding the "service" account).
50IBM_EXTRA_USERS_PARAMS += " \
51 groupadd wheel; \
52 "
53
54# Add the "admin" account.
55IBM_EXTRA_USERS_PARAMS += " \
56 useradd -M -d / --groups priv-admin,redfish,web -s /sbin/nologin admin; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050057 usermod -p ${DEFAULT_OPENBMC_PASSWORD} admin; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060058 "
59
60# Add the "service" account.
61IBM_EXTRA_USERS_PARAMS += " \
62 useradd -M -d / --groups priv-admin,redfish,web,wheel service; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050063 usermod -p ${DEFAULT_OPENBMC_PASSWORD} service; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060064 "
65
66# This is recipe specific to ensure it takes effect.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000067EXTRA_USERS_PARAMS:pn-obmc-phosphor-image += "${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', "${IBM_EXTRA_USERS_PARAMS}", '', d)}"
Joseph Reynolds68e567f2021-02-24 17:20:01 -060068
69# The service account needs sudo.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000070IMAGE_INSTALL:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', 'sudo', '', d)}"