blob: 57a3ae005bce56e12a4c1a6f28184f09853c1f6a [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007LICENSE = "GPLv2+"
Brad Bishop19323692019-04-05 15:28:33 -04008LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050010SRCREV = "cce0edb4282ee081d043030bfdf29f3e4052f86c"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050011PV .= "+git${SRCPV}"
Brad Bishop19323692019-04-05 15:28:33 -040012
Brad Bishopd89cb5f2019-04-10 09:02:41 -040013SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
Brad Bishop15ae2502019-06-18 21:44:24 -040014"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040015
Brad Bishop19323692019-04-05 15:28:33 -040016S = "${WORKDIR}/git"
17
18FILES_${PN} = "${bindir}/ptest-runner"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
28}