blob: 10b4c5b6a408e8d59c64ea3410bd2c2ae880788b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050010SRCREV = "834670317bd3f6e427e1ac461c07ada6b8936dfd"
11PV .= "+git${SRCPV}"
Brad Bishop19323692019-04-05 15:28:33 -040012
Brad Bishopd89cb5f2019-04-10 09:02:41 -040013SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
Brad Bishop15ae2502019-06-18 21:44:24 -040014"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050015UPSTREAM_VERSION_UNKNOWN = "1"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040016
Brad Bishop19323692019-04-05 15:28:33 -040017S = "${WORKDIR}/git"
18
19FILES_${PN} = "${bindir}/ptest-runner"
20
21EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
22
23do_compile () {
24 oe_runmake
25}
26
27do_install () {
28 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
29}