Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Interface for user-level network packet capture" |
| 2 | DESCRIPTION = "Libpcap provides a portable framework for low-level network \ |
| 3 | monitoring. Libpcap can provide network statistics collection, \ |
| 4 | security monitoring and network debugging." |
| 5 | HOMEPAGE = "http://www.tcpdump.org/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577" |
| 7 | SECTION = "libs/network" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \ |
| 10 | file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2" |
| 11 | DEPENDS = "flex-native bison-native" |
| 12 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 13 | SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz" |
| 14 | SRC_URI[sha256sum] = "ed285f4accaf05344f90975757b3dbfe772ba41d1c401c2648b7fa45b711bdd4" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 16 | inherit autotools binconfig-disabled pkgconfig |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
| 18 | BINCONFIG = "${bindir}/pcap-config" |
| 19 | |
| 20 | # Explicitly disable dag support. We don't have recipe for it and if enabled here, |
| 21 | # configure script poisons the include dirs with /usr/local/include even when the |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 22 | # support hasn't been detected. Do the same thing for DPDK. |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | EXTRA_OECONF = " \ |
| 24 | --with-pcap=linux \ |
| 25 | --without-dag \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 26 | --without-dpdk \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | " |
| 28 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 29 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 30 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 32 | " |
| 33 | PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5" |
| 34 | PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus" |
| 35 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 36 | PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl" |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | do_configure:prepend () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | #remove hardcoded references to /usr/include |
| 40 | sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |