Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "ITS Tool allows you to translate your XML documents with PO files" |
| 2 | DESCRIPTION = "It extracts messages from XML files and outputs PO template \ |
| 3 | files, then merges translations from MO files to create translated \ |
| 4 | XML files. It determines what to translate and how to chunk it into \ |
| 5 | messages using the W3C Internationalization Tag Set (ITS). " |
| 6 | HOMEPAGE = "http://itstool.org/" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 7 | LICENSE = "GPL-3.0-only" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "\ |
| 9 | file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5 \ |
| 10 | file://COPYING.GPL3;md5=d32239bcb673463ab874e80d47fae504 \ |
| 11 | " |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 12 | |
| 13 | inherit autotools python3native |
| 14 | |
| 15 | DEPENDS = "libxml2-native" |
| 16 | |
| 17 | SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 18 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 19 | UPSTREAM_CHECK_URI = "https://itstool.org/download.html" |
| 20 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 21 | SRC_URI:append:class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 22 | SRC_URI:append:class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 23 | SRC_URI:append:class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch" |
| 24 | |
| 25 | SRC_URI[sha256sum] = "6b9a7cd29a12bb95598f5750e8763cee78836a1a207f85b74d8b3275b27e87ca" |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |
| 29 | RDEPENDS:${PN} += "libxml2-python" |