blob: dece2a3d9a14538e45b604278b39affc26223c2a [file] [log] [blame]
Brad Bishopce718f92017-01-12 22:12:01 -05001SUMMARY = "Phosphor Inventory Manager"
2DESCRIPTION = "Phosphor Inventory Manager is an inventory object \
3lifecycle management application, suitable for use on a wide variety \
4of OpenBMC platforms."
5PR = "r1"
Patrick Ventured149d4a2018-10-17 07:48:17 -07006PV = "1.0+git${SRCPV}"
Brad Bishopce718f92017-01-12 22:12:01 -05007
8inherit autotools \
9 pkgconfig \
10 pythonnative \
Marri Devender Raoc84d4132017-06-08 23:53:04 -050011 phosphor-dbus-yaml \
Brad Bishopb7d3a492017-01-28 15:28:17 -050012 phosphor-inventory-manager \
Brad Bishopce718f92017-01-12 22:12:01 -050013 obmc-phosphor-dbus-service
14
15require phosphor-inventory-manager.inc
16
17DEPENDS += " \
Brad Bishopbd44fa82019-05-22 19:21:40 -040018 phosphor-inventory-manager-assettag \
Brad Bishop286df172017-02-13 22:51:36 -050019 phosphor-dbus-interfaces \
Brad Bishop15947ed2017-02-15 14:11:50 -050020 phosphor-dbus-interfaces-native \
21 phosphor-logging \
Brad Bishopce718f92017-01-12 22:12:01 -050022 sdbusplus \
Patrick Williams4b32c9a2020-03-31 16:43:15 -050023 ${PYTHON_PN}-sdbus++-native \
Brad Bishopce718f92017-01-12 22:12:01 -050024 autoconf-archive-native \
Brad Bishop17c08bf2018-10-18 17:07:53 -040025 libcereal \
Andrew Geisslerb49af0c2020-03-05 09:27:35 -060026 ${PYTHON_PN}-native \
27 ${PYTHON_PN}-pyyaml-native \
28 ${PYTHON_PN}-mako-native \
Brad Bishopce718f92017-01-12 22:12:01 -050029 "
Brad Bishopce718f92017-01-12 22:12:01 -050030
Brad Bishop296b27c2017-02-23 10:44:48 -050031OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"
Brad Bishopce718f92017-01-12 22:12:01 -050032OBMC_INVENTORY_MGR_IFACE="${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
33
34DBUS_SERVICE_${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
35
36S = "${WORKDIR}/git"
37
38EXTRA_OECONF = " \
Brad Bishopbd44fa82019-05-22 19:21:40 -040039 YAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
Brad Bishopce718f92017-01-12 22:12:01 -050040 BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
41 INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
42 IFACE=${OBMC_INVENTORY_MGR_IFACE} \
Brad Bishopbd44fa82019-05-22 19:21:40 -040043 IFACES_PATH=${STAGING_DIR_HOST}${yaml_dir} \
Brad Bishopce718f92017-01-12 22:12:01 -050044 "
Matt Spinler0bf37932019-03-11 16:24:03 -050045
46PACKAGECONFIG ??= ""
47PACKAGECONFIG[associations] = "--enable-associations, --disable-associations,nlohmann-json,"