blob: 105ba10d7a9b59395a6705cd6ea6efb0ceb6b0d8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
Brad Bishop36a3e3e2019-10-02 13:29:27 -04006LIC_FILES_CHKSUM = "file://COPYING;md5=0e5b01c848c7736a0c9e68f9c9cd0281"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007
8DEPENDS += "kea-native"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
Brad Bishop15ae2502019-06-18 21:44:24 -040012 file://0001-remove-AC_TRY_RUN.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013 file://kea-dhcp4.service \
14 file://kea-dhcp6.service \
15 file://kea-dhcp-ddns.service \
16"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040017SRC_URI[md5sum] = "c6406ac3d160161056d2fc36557ebd89"
18SRC_URI[sha256sum] = "173c8e893690a611bc1d1c6fbe54a5c20fcd54429399a8dc3a0d7d2eb01bf8cc"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
20inherit autotools systemd
21
22SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
23SYSTEMD_AUTO_ENABLE = "disable"
24
Brad Bishop15ae2502019-06-18 21:44:24 -040025DEBUG_OPTIMIZATION_remove_mips = " -Og"
26DEBUG_OPTIMIZATION_append_mips = " -O"
27BUILD_OPTIMIZATION_remove_mips = " -Og"
28BUILD_OPTIMIZATION_append_mips = " -O"
29
30DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
31DEBUG_OPTIMIZATION_append_mipsel = " -O"
32BUILD_OPTIMIZATION_remove_mipsel = " -Og"
33BUILD_OPTIMIZATION_append_mipsel = " -O"
34
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035do_configure_prepend_class-target() {
36 mkdir -p ${B}/src/lib/log/compiler/
37 ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
38}
39
40do_install_append_class-target() {
41 install -d ${D}${systemd_system_unitdir}
42 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
43 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
44 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
45 ${D}${systemd_system_unitdir}/kea-dhcp*service
46}
47
48do_install_append() {
49 rm -rf "${D}${localstatedir}"
50}
51
52PACKAGECONFIG ??= "openssl log4cplus boost"
53
54PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl"
55PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040056PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057
58FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
59FILES_${PN} += "${libdir}/hooks/*.so"
60
61BBCLASSEXTEND += "native"
Brad Bishop4fe7a132019-10-07 09:34:48 -040062
63PARALLEL_MAKEINST = ""