blob: da051c119f92a8693d4012fc4fffdc6c3417a054 [file] [log] [blame]
Andrew Geissler5a43b432020-06-13 10:46:56 -05001SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things."
Andrew Geissler5a43b432020-06-13 10:46:56 -05004
Andrew Geissler5199d832021-09-24 16:47:35 -05005LICENSE = "xinetd"
Andrew Geissler5a43b432020-06-13 10:46:56 -05006LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
7
8UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
9
10SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \
11 file://xinetd.init \
12 file://xinetd.default \
13 file://xinetd.service \
14 "
15
16SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
17
18S = "${WORKDIR}/git"
19
William A. Kennington IIIac69b482021-06-02 12:28:27 -070020# https://github.com/xinetd-org/xinetd/pull/10 is merged into this git tree revision
21CVE_CHECK_WHITELIST += "CVE-2013-4342"
22
Andrew Geissler5a43b432020-06-13 10:46:56 -050023inherit autotools update-rc.d systemd pkgconfig
24
Patrick Williams213cb262021-08-07 19:21:33 -050025SYSTEMD_SERVICE:${PN} = "xinetd.service"
Andrew Geissler5a43b432020-06-13 10:46:56 -050026
27INITSCRIPT_NAME = "xinetd"
28INITSCRIPT_PARAMS = "defaults"
29
30PACKAGECONFIG ??= "tcp-wrappers"
31PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033CONFFILES:${PN} = "${sysconfdir}/xinetd.conf"
Andrew Geissler5a43b432020-06-13 10:46:56 -050034
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append() {
Andrew Geissler5a43b432020-06-13 10:46:56 -050036 install -d "${D}${sysconfdir}/init.d"
37 install -d "${D}${sysconfdir}/default"
38 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
39 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
40
41 # Install systemd unit files
Andrew Geissler5199d832021-09-24 16:47:35 -050042 install -d ${D}${systemd_system_unitdir}
43 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_system_unitdir}
Andrew Geissler5a43b432020-06-13 10:46:56 -050044 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
45 -e 's,@SBINDIR@,${sbindir},g' \
Andrew Geissler5199d832021-09-24 16:47:35 -050046 ${D}${systemd_system_unitdir}/xinetd.service
Andrew Geissler5a43b432020-06-13 10:46:56 -050047}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049RDEPENDS:${PN} += "perl"