Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager." |
| 2 | SUMMARY = "EFI Boot Manager" |
| 3 | HOMEPAGE = "https://github.com/rhboot/efibootmgr" |
| 4 | SECTION = "base" |
| 5 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 8 | |
| 9 | DEPENDS = "efivar popt" |
| 10 | |
| 11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 12 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https;branch=main" |
| 14 | SRCREV = "c3f9f0534e32158f62c43564036878b93b9e0fd6" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit pkgconfig |
| 19 | |
| 20 | # The directory under the ESP that the default bootloader is found in. When |
| 21 | # wic uses a subdirectory, this should use the same one too. |
| 22 | EFIDIR ?= "/" |
| 23 | |
| 24 | EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'" |
| 25 | |
| 26 | CFLAGS += " -Wno-error" |
| 27 | |
| 28 | do_install () { |
| 29 | oe_runmake install DESTDIR="${D}" |
| 30 | } |
| 31 | |
| 32 | CLEANBROKEN = "1" |