Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Power usage tool" |
| 2 | DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | HOMEPAGE = "https://01.org/powertop/" |
| 4 | BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla" |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 5 | DEPENDS = "ncurses libnl pciutils autoconf-archive" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 8 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 9 | SRC_URI = "git://github.com/fenrus75/powertop;protocol=https \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 10 | file://0001-wakeup_xxx.h-include-limits.h.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | " |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 12 | SRCREV = "184cee06b2d64679bae5f806fe0a218827fdde99" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 14 | S = "${WORKDIR}/git" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 16 | inherit autotools gettext pkgconfig bash-completion |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | # we do not want libncursesw if we can |
| 19 | do_configure_prepend() { |
| 20 | # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one |
| 21 | sed -i -e "s/ncursesw//g" ${S}/configure.ac |
| 22 | mkdir -p ${B}/src/tuning/ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 23 | echo "${PV}" > ${S}/version-long |
| 24 | echo "${PV}" > ${S}/version-short |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 25 | cp ${STAGING_DATADIR}/aclocal/ax_require_defined.m4 ${S}/m4/ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | } |
| 27 | |
| 28 | inherit update-alternatives |
| 29 | ALTERNATIVE_${PN} = "powertop" |
| 30 | ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop" |
| 31 | ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop" |
| 32 | ALTERNATIVE_PRIORITY = "100" |