blob: 594ac949f414308da58b4e242f93fafbc1ebdbb9 [file] [log] [blame]
Patrick Venture6dd5cc92018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
Patrick Venture24d981d2019-06-28 15:34:15 -07005PV = "1.0+git${SRCPV}"
Patrick Venture6dd5cc92018-11-09 18:27:28 -08006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
Andrew Geisslerbae19af2019-07-08 19:51:12 +000011inherit systemd
Patrick Venture6dd5cc92018-11-09 18:27:28 -080012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "phosphor-ipmi-blobs"
15DEPENDS += "phosphor-logging"
16DEPENDS += "sdbusplus"
Andrew Geisslerbae19af2019-07-08 19:51:12 +000017DEPENDS += "systemd"
Patrick Venturea9f19bd2019-03-07 10:51:53 -080018DEPENDS += "ipmi-blob-tool"
Patrick Venturea26ccf52019-05-03 10:35:28 -070019DEPENDS += "pciutils"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080020
Andrew Geissler79ca37b2019-06-19 18:52:19 +000021PACKAGECONFIG ?= "cleanup-delete"
22PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
Patrick Venturee4c64072019-06-28 19:28:28 -070023# If using static-layout, reboot-update is a good option to handle updating.
Brandon Kimc0323d62019-09-17 17:14:48 -070024# To be able to track the update status, update-status option can be used.
25# Note that both reboot-update and update-status cannot be enabled at the same time.
Patrick Venturee4c64072019-06-28 19:28:28 -070026PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
Brandon Kimc0323d62019-09-17 17:14:48 -070027PACKAGECONFIG[update-status] = "--enable-update-status, --disable-update-status"
Patrick Venture5bcb8672019-07-19 14:07:22 -070028
29# Default options for supporting various flash types:
30PACKAGECONFIG[static-bmc] = "--enable-static-layout, --disable-static-layout"
31PACKAGECONFIG[ubitar-bmc] = "--enable-tarball-ubi, --disable-tarball-ubi"
Andrew Geisslerbae19af2019-07-08 19:51:12 +000032PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
Andrew Geissler79ca37b2019-06-19 18:52:19 +000033
Patrick Venture700db3c2019-07-15 09:39:43 -070034# Hardware options to enable transmitting the data from the host.
35PACKAGECONFIG[aspeed-p2a] = "--enable-aspeed-p2a, --disable-aspeed-p2a"
36PACKAGECONFIG[aspeed-lpc] = "--enable-aspeed-lpc, --disable-aspeed-lpc"
37PACKAGECONFIG[nuvoton-lpc] = "--enable-nuvoton-lpc, --disable-nuvoton-lpc"
Benjamin Fair264dcc02019-10-17 16:55:54 -070038PACKAGECONFIG[net-bridge] = "--enable-net-bridge, --disable-net-bridge"
Patrick Venture700db3c2019-07-15 09:39:43 -070039
Patrick Venture51c0f092019-05-15 12:19:16 -070040EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
41
Patrick Ventured190c732019-07-15 09:50:03 -070042# Set this variable in your recipe to set it instead of using MAPPED_ADDRESS directly.
43IPMI_FLASH_BMC_ADDRESS ?= "0"
44EXTRA_OECONF_append = " MAPPED_ADDRESS=${IPMI_FLASH_BMC_ADDRESS}"
45
Patrick Venture6dd5cc92018-11-09 18:27:28 -080046S = "${WORKDIR}/git"
47SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geissler5ef22cf2020-10-27 18:11:26 +000048SRCREV = "56a2273fc7e609ddac670a57d55089d24448025a"
Andrew Geisslerbae19af2019-07-08 19:51:12 +000049
50SYSTEMD_PACKAGES = "${PN}"
51SYSTEMD_SERVICE_${PN} += "phosphor-ipmi-flash-bmc-prepare.target \
52 phosphor-ipmi-flash-bmc-verify.target \
53 phosphor-ipmi-flash-bmc-update.target"
54
55# If they enabled host-bios, add those three extra targets.
56HOST_BIOS_TARGETS = "phosphor-ipmi-flash-bios-prepare.target \
57 phosphor-ipmi-flash-bios-verify.target \
58 phosphor-ipmi-flash-bios-update.target"
59
60SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'host-bios', '${HOST_BIOS_TARGETS}', '', d)}"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080061
62FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
63FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
64FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
65
66BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"
Andrew Geissler79ca37b2019-06-19 18:52:19 +000067BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}"
Patrick Venture3c1a03b2019-05-08 07:43:10 -070068
69do_configure[depends] += "virtual/kernel:do_shared_workdir"