Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Dibbler DHCPv6 client" |
| 2 | DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6." |
| 3 | HOMEPAGE = "http://klub.com.pl/dhcpv6" |
| 4 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3" |
| 7 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 8 | SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SRC_URI = "git://github.com/tomaszmrugalski/dibbler;branch=master;protocol=https \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | file://dibbler_fix_getSize_crash.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 12 | file://0001-port-linux-Re-order-header-includes.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | PV = "1.0.1+1.0.2RC1+git${SRCREV}" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update" |
| 19 | |
| 20 | PACKAGECONFIG[debug] = "--enable-debug,,," |
| 21 | PACKAGECONFIG[efence] = "--enable-efence,,," |
| 22 | PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,," |
| 23 | PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,," |
| 24 | PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,," |
| 25 | PACKAGECONFIG[dns-update] = "--enable-dns-update,,," |
| 26 | PACKAGECONFIG[auth] = "--enable-auth,,," |
| 27 | PACKAGECONFIG[gtest] = "--enable-gtest-static,,," |
| 28 | |
| 29 | inherit autotools |
| 30 | |
| 31 | DEPENDS += "flex-native" |
| 32 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 33 | CFLAGS += "-D_GNU_SOURCE" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 34 | LDFLAGS += "-pthread" |
| 35 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 36 | PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server" |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN}-client = "${sbindir}/${PN}-client" |
| 39 | FILES:${PN}-relay = "${sbindir}/${PN}-relay" |
| 40 | FILES:${PN}-requestor = "${sbindir}/${PN}-requestor" |
| 41 | FILES:${PN}-server = "${sbindir}/${PN}-server" |