blob: 607f236c2a18268598b21195a080ee89eeadf57f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
6 file://0001-tests-Fix-missing-include-of-Xutil.h.patch"
7
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008# From 2015-02-19
9SRCREV = "c4585427913e4cb28994b4bfb11d49778273aa2c"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010# (when PV goes above 1.0 remove the trailing r)
11PV = "1.0+gitr${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native"
16
17inherit cmake pythonnative distro_features_check
18# depends on virtual/libx11
19REQUIRED_DISTRO_FEATURES = "x11"
20
Patrick Williamsf1e5d692016-03-30 15:21:19 -050021# The built scripts go into the temporary directory according to tempfile
22# (typically /tmp) which can race if multiple builds happen on the same machine,
23# so tell it to use a directory in ${B} to avoid overwriting.
24export TEMP = "${B}/temp/"
25do_compile[dirs] =+ "${B}/temp/"
26
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027PACKAGECONFIG ??= ""
28PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
29
30do_configure_prepend() {
31 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
32 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
33 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
34 fi
35}
36
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050038 python-argparse python-importlib python-unixadmin python-xml \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 python-multiprocessing python-textutils python-netserver python-shell \
40 mesa-demos bash \
41 "
42
43INSANE_SKIP_${PN} += "dev-so"