blob: 9afd6714f0d55c2904b8d8afbd77b61a814214e9 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Build tools needed by external modules"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.yoctoproject.org/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003LICENSE = "GPL-2.0-only"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005
6inherit kernel-arch
7inherit pkgconfig
8
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11S = "${WORKDIR}"
12
13do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot"
14do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
15
Andrew Geissler615f2f12022-07-15 14:00:58 -050016DEV_PKG_DEPENDENCY = ""
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050017
Brad Bishopf3fd2882019-06-21 08:06:37 -040018DEPENDS += "bc-native bison-native"
Andrew Geissler635e0e42020-08-21 15:58:33 -050019DEPENDS += "gmp-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020
21EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050022EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}" CROSS_COMPILE=${TARGET_PREFIX}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040023
24# Build some host tools under work-shared. CC, LD, and AR are probably
25# not used, but this is the historical way of invoking "make scripts".
26#
27do_configure() {
28 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
Andrew Geissler4ed12e12020-06-05 18:00:41 -050029 for t in prepare scripts_basic scripts; do
30 oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
31 -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t
32 done
Brad Bishop316dfdd2018-06-25 12:45:53 -040033}