blob: d60cee87c9bce13fba2cd6624d100836186be935 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Userspace NFS server v3 protocol"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \
3specification. It provides a daemon for the MOUNT and NFS protocols, which \
4are used by NFS clients for accessing files on the server."
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05005SECTION = "console/network"
6LICENSE = "unfs3"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
8
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05009DEPENDS = "flex-native bison-native flex"
Brad Bishop00111322018-04-01 22:23:53 -040010DEPENDS += "libtirpc"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011DEPENDS_append_class-nativesdk = " flex-nativesdk"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012
Brad Bishop00111322018-04-01 22:23:53 -040013ASNEEDED = ""
14
Brad Bishop96ff1982019-08-19 13:50:42 -040015S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017 file://unfs3_parallel_build.patch \
18 file://alternate_rpc_ports.patch \
19 file://fix_pid_race_parent_writes_child_pid.patch \
20 file://fix_compile_warning.patch \
21 file://rename_fh_cache.patch \
22 file://relative_max_socket_path_len.patch \
23 file://tcp_no_delay.patch \
Brad Bishop00111322018-04-01 22:23:53 -040024 file://0001-daemon.c-Libtirpc-porting-fixes.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025 file://0001-attr-fix-utime-for-symlink.patch \
Brad Bishop64c979e2019-11-04 13:55:29 -050026 file://0001-Add-listen-action-for-a-tcp-socket.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 "
Brad Bishop96ff1982019-08-19 13:50:42 -040028SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425"
29UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)"
30
31PV = "0.9.22+${SRCPV}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050032
33BBCLASSEXTEND = "native nativesdk"
34
35inherit autotools
36EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
Brad Bishop00111322018-04-01 22:23:53 -040037CFLAGS_append = " -I${STAGING_INCDIR}/tirpc"
38LDFLAGS_append = " -ltirpc"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039
40# Turn off these header detects else the inode search
41# will walk entire file systems and this is a real problem
42# if you have 2 TB of files to walk in your file system
43CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"