blob: 46f5fbc6be9d7221e58f50e156834e544e2720cd [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
Patrick Williamse760df82023-05-26 11:10:49 -05006CGO_LDFLAGS:append = " -no-pie"
Patrick Williams03907ee2022-05-01 06:28:52 -05007
Andrew Geisslerc9f78652020-09-18 14:11:35 -05008export GO_LDSO = "${@get_linuxloader(d)}"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009export CC_FOR_TARGET = "gcc"
10export CXX_FOR_TARGET = "g++"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050011
Andrew Geissler90fd73c2021-03-05 15:25:55 -060012# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
Andrew Geisslerc9f78652020-09-18 14:11:35 -050013# variants.
14python() {
Patrick Williams864cc432023-02-09 14:54:44 -060015 if 'mips' in d.getVar('TARGET_ARCH') or 'riscv32' in d.getVar('TARGET_ARCH'):
16 d.appendVar('INSANE_SKIP:%s' % d.getVar('PN'), " textrel")
Andrew Geisslerc9f78652020-09-18 14:11:35 -050017}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018