blob: f0ae8b36bd1d0308cc91e52c0d0e44d26b94133c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg.conf \
16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
Brad Bishop6dbb3162019-11-25 09:41:34 -050017 file://opkg_archive.patch \
18 file://open_inner.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040019 file://run-ptest \
Brad Bishop19323692019-04-05 15:28:33 -040020"
21
Brad Bishop96ff1982019-08-19 13:50:42 -040022SRC_URI[md5sum] = "ba0c21305fc93b26e844981ef100dc85"
23SRC_URI[sha256sum] = "45ac1e037d3877f635d883f8a555e172883a25d3eeb7986c75890fdd31250a43"
Brad Bishop19323692019-04-05 15:28:33 -040024
Brad Bishopc342db32019-05-15 21:57:59 -040025# This needs to be before ptest inherit, otherwise all ptest files end packaged
26# in libopkg package if OPKGLIBDIR == libdir, because default
27# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
28PACKAGES =+ "libopkg"
29
Brad Bishop00e122a2019-10-05 11:10:57 -040030inherit autotools pkgconfig ptest
Brad Bishop19323692019-04-05 15:28:33 -040031
32target_localstatedir := "${localstatedir}"
Brad Bishop96ff1982019-08-19 13:50:42 -040033OPKGLIBDIR ??= "${target_localstatedir}/lib"
Brad Bishop19323692019-04-05 15:28:33 -040034
35PACKAGECONFIG ??= "libsolv"
36
Brad Bishop1d80a2e2019-11-15 16:35:03 -050037PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
38 gnupg gpgme libgpg-error,\
39 ${@ "gnupg" if ("native" in d.getVar("PN")) else "gnupg-gpg"}\
40 "
Brad Bishop19323692019-04-05 15:28:33 -040041PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
42PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
43PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
44PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
Brad Bishop19323692019-04-05 15:28:33 -040045PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
46
Brad Bishop00e122a2019-10-05 11:10:57 -040047EXTRA_OECONF += " --disable-pathfinder"
Brad Bishop19323692019-04-05 15:28:33 -040048EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
49
Brad Bishop96ff1982019-08-19 13:50:42 -040050# Release tarball has unused binaries on the tests folder, automatically created by automake.
51# For now, delete them to avoid packaging errors (wrong architecture)
52do_unpack_append () {
53 bb.build.exec_func('remove_test_binaries', d)
54}
55
56remove_test_binaries () {
57 rm ${WORKDIR}/opkg-${PV}/tests/libopkg_test*
58}
59
Brad Bishop19323692019-04-05 15:28:33 -040060do_install_append () {
61 install -d ${D}${sysconfdir}/opkg
62 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
63 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
64
65 # We need to create the lock directory
66 install -d ${D}${OPKGLIBDIR}/opkg
67}
68
Brad Bishop96ff1982019-08-19 13:50:42 -040069do_install_ptest () {
70 sed -i -e '/@echo $^/d' ${D}${PTEST_PATH}/tests/Makefile
71 sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
72}
73
Brad Bishop19323692019-04-05 15:28:33 -040074RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
75RDEPENDS_${PN}_class-native = ""
76RDEPENDS_${PN}_class-nativesdk = ""
Brad Bishopc342db32019-05-15 21:57:59 -040077RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression"
Brad Bishop19323692019-04-05 15:28:33 -040078RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
79RCONFLICTS_${PN} = "opkg-collateral"
80RPROVIDES_${PN} = "opkg-collateral"
81
Brad Bishop19323692019-04-05 15:28:33 -040082FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
83
84BBCLASSEXTEND = "native nativesdk"
85
86CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"