blob: 8d19ce4283e3db9dd24b4e0ed1d26ead7328d120 [file] [log] [blame]
Patrick Venture7ebe0262018-03-30 11:23:16 -07001SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
Patrick Venture6b91f732018-09-28 19:21:26 -07003HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
Patrick Venture7ebe0262018-03-30 11:23:16 -07004PR = "r1"
Patrick Venture6b91f732018-09-28 19:21:26 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture7ebe0262018-03-30 11:23:16 -07008
9inherit autotools pkgconfig
10inherit obmc-phosphor-systemd
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
Kun Yi41d3e4d2018-09-12 11:01:33 -070014DEPENDS += "sdeventplus"
Patrick Venture7ebe0262018-03-30 11:23:16 -070015DEPENDS += "phosphor-dbus-interfaces"
16DEPENDS += "systemd"
17
Kun Yi41d3e4d2018-09-12 11:01:33 -070018RDEPENDS_${PN} += "sdbusplus sdeventplus phosphor-dbus-interfaces"
Patrick Venture7ebe0262018-03-30 11:23:16 -070019
Patrick Venture6b91f732018-09-28 19:21:26 -070020S = "${WORKDIR}/git"
21SRC_URI = "git://github.com/openbmc/phosphor-host-postd"
22SRCREV = "1c16ad897b629442c6682e5d5062bdaad6caa150"
23
Benjamin Fair89e86cd2018-06-29 13:00:14 -070024SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
25POST_CODE_BYTES ?= "1"
26
27SERVICE_FILE = "lpcsnoop.service"
28SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
29SYSTEMD_SUBSTITUTIONS += "SNOOP_DEVICE:${SNOOP_DEVICE}:${SERVICE_FILE}"
30SYSTEMD_SUBSTITUTIONS += "POST_CODE_BYTES:${POST_CODE_BYTES}:${SERVICE_FILE}"