blob: 9cb8bfdbab8e9975628a9792af4d449b08a27a9d [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using python.
2
3inherit allarch
4inherit obmc-phosphor-systemd
5inherit obmc-phosphor-license
6
7RDEPENDS_${PN} += "python-dbus python-pygobject"
Brad Bishop51607d22015-10-18 22:00:15 -04008INSTALL_NAME ?= "${PN}"
9SCRIPT_NAME ?= "${INSTALL_NAME}.py"
Brad Bishop93fb5352015-09-09 03:59:20 +000010
11do_install_append() {
12 # install the script
13 install -d ${D}${sbindir}
Brad Bishop51607d22015-10-18 22:00:15 -040014 install -m 0755 ${S}/${SCRIPT_NAME} ${D}${sbindir}/${INSTALL_NAME}
Brad Bishop93fb5352015-09-09 03:59:20 +000015}