blob: f2942b9e37d0576c41d37925199f9e71586dc7a7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
Brad Bishop316dfdd2018-06-25 12:45:53 -04003RDEPENDS_${PN}-common += "${PN}-editenv"
Brad Bishopa34c0302019-09-23 22:34:48 -04004RDEPENDS_${PN} += "${PN}-common"
Andrew Geisslerd25ed322020-06-27 00:28:28 -05005RDEPENDS_${PN}_class-native = ""
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
7RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
8
Andrew Geisslerd25ed322020-06-27 00:28:28 -05009PROVIDES_append_class-native = " grub-efi-native"
10
Brad Bishop316dfdd2018-06-25 12:45:53 -040011PACKAGES =+ "${PN}-editenv ${PN}-common"
12FILES_${PN}-editenv = "${bindir}/grub-editenv"
13FILES_${PN}-common = " \
14 ${bindir} \
15 ${sysconfdir} \
16 ${sbindir} \
17 ${datadir}/grub \
18"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
Brad Bishop08902b02019-08-20 09:16:51 -040020FILES_${PN}-common_append_aarch64 = " \
21 ${libdir}/${BPN} \
22"
23
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024do_install_append () {
25 install -d ${D}${sysconfdir}/grub.d
26 # Remove build host references...
27 find "${D}" -name modinfo.sh -type f -exec \
28 sed -i \
29 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
30 -e 's|${DEBUG_PREFIX_MAP}||g' \
31 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
32 {} +
33}
34
35INSANE_SKIP_${PN} = "arch"
36INSANE_SKIP_${PN}-dbg = "arch"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050037
Andrew Geissler6ce62a22020-11-30 19:58:47 -060038BBCLASSEXTEND = "native nativesdk"