blob: 2ea57794a6e3b0b47087f1ec0709de67fb0b7f99 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008 file://0001-CMake-define-GBM_BO_MAP-only-when-symbol-is-found.patch \
9 file://0002-util-egl-Honour-Surfaceless-MESA-in-get_default_disp.patch \
10 file://0003-egl_mesa_platform_surfaceless-Don-t-use-eglGetPlatfo.patch \
11 file://0004-egl_mesa_platform_surfaceless-Use-EXT-functions-for-.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014# From 2017-02-06
15SRCREV = "ca58eec0b965655c7eba592a634cbf4aadfbc675"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016# (when PV goes above 1.0 remove the trailing r)
17PV = "1.0+gitr${SRCPV}"
18
19S = "${WORKDIR}/git"
20
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023inherit cmake python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024# depends on virtual/libx11
25REQUIRED_DISTRO_FEATURES = "x11"
26
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# depends on virtual/libgl
28REQUIRED_DISTRO_FEATURES += "opengl"
29
Patrick Williamsf1e5d692016-03-30 15:21:19 -050030# The built scripts go into the temporary directory according to tempfile
31# (typically /tmp) which can race if multiple builds happen on the same machine,
32# so tell it to use a directory in ${B} to avoid overwriting.
33export TEMP = "${B}/temp/"
34do_compile[dirs] =+ "${B}/temp/"
35
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036PACKAGECONFIG ??= ""
37PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
38
39do_configure_prepend() {
40 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
41 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
42 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
43 fi
44}
45
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046do_install() {
47 oe_runmake -C ${B} 'DESTDIR=${D}' install/strip
48}
49
50RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
51 python3-subprocess python3-misc python3-importlib \
52 python3-unixadmin python3-xml python3-multiprocessing \
53 python3-six python3-shell python3-io python3-argparse \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050054 python3-netserver mesa-demos bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055 "
56
Patrick Williamsc0f7c042017-02-23 20:41:17 -060057INSANE_SKIP_${PN} += "dev-so already-stripped"