blob: 099c58bfc712815a60e7278ad0c59d5ea0193e75 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Enables PPP dial-in through a serial connection"
2SECTION = "console/network"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "PPP dail-in provides a point to point protocol (PPP), so that other computers can dial up to it and access connected networks."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004DEPENDS = "ppp"
Patrick Williams213cb262021-08-07 19:21:33 -05005RDEPENDS:${PN} = "ppp"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9SRC_URI = "file://host-peer \
10 file://ppp-dialin"
11
12inherit allarch useradd
13
14S = "${WORKDIR}"
15
16do_install() {
17 install -d ${D}${sysconfdir}/ppp/peers
18 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
19
20 install -d ${D}${sbindir}
21 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
22}
23
24USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050025USERADD_PARAM:${PN} = "--system --home /dev/null \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 --no-create-home --shell ${sbindir}/ppp-dialin \
27 --no-user-group --gid nogroup ppp"