Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Tools to manipulate UEFI variables" |
| 2 | DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility" |
| 3 | HOMEPAGE = "https://github.com/rhboot/efivar" |
| 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "LGPL-2.1-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
| 7 | |
| 8 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 9 | |
| 10 | SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \ |
| 11 | file://0001-docs-do-not-build-efisecdb-manpage.patch \ |
| 12 | file://0001-src-Makefile-build-util.c-separately-for-makeguids.patch \ |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 13 | file://efisecdb-fix-build-with-musl-libc.patch \ |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 14 | file://0001-Fix-invalid-free-in-main.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 15 | file://0001-Fix-glibc-2.36-build-mount.h-conflicts.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | file://0001-Use-off_t-instead-of-off64_t.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | " |
| 18 | SRCREV = "1753149d4176ebfb2b135ac0aaf79340bf0e7a93" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit pkgconfig |
| 23 | |
| 24 | export CCLD_FOR_BUILD = "${BUILD_CCLD}" |
| 25 | |
| 26 | # Upstream uses --add-needed in gcc.specs which gold doesn't support, so |
| 27 | # enforce BFD. |
| 28 | LDFLAGS += "-fuse-ld=bfd" |
| 29 | |
| 30 | do_compile() { |
| 31 | oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}" |
| 32 | } |
| 33 | |
| 34 | do_install() { |
| 35 | oe_runmake install DESTDIR=${D} |
| 36 | } |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |
| 39 | |
| 40 | RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs" |
| 41 | |
| 42 | CLEANBROKEN = "1" |