blob: 76ba70e502b31b8444eb5f6666b1b480447c2b75 [file] [log] [blame]
Jeremy Kerr882199e2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
Jeremy Kerr882199e2016-03-17 17:35:27 +08007
Jeremy Kerr882199e2016-03-17 17:35:27 +08008inherit obmc-phosphor-systemd
9inherit autotools
Ratan Guptadf7dfd42016-10-01 14:57:15 -050010inherit obmc-phosphor-discovery-service
Jeremy Kerr882199e2016-03-17 17:35:27 +080011
12TARGET_CFLAGS += "-fpic -O2"
13
Matthew Barth3e20a722016-09-26 16:26:27 -050014DEPENDS += "autoconf-archive-native"
15
Jeremy Kerr882199e2016-03-17 17:35:27 +080016SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishopf75c9602016-08-30 14:14:24 -040017SRC_URI += "file://${PN}.conf"
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080018
Andrew Geissler51abd0d2018-09-07 01:50:15 +000019SRCREV = "1864435759305800aeda41fc3e37baceb5762116"
Brad Bishop586e22612018-04-12 11:11:49 -040020PV = "1.0+git${SRCPV}"
Jeremy Kerr882199e2016-03-17 17:35:27 +080021
Ratan Guptadf7dfd42016-10-01 14:57:15 -050022REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
Vishwanatha Subbannae4bfd682016-10-01 11:34:42 -050023OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
24SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
Yi Lif1c10dd2016-10-21 12:08:47 +080025SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
Ratan Guptadf7dfd42016-10-01 14:57:15 -050026
Brad Bishopf75c9602016-08-30 14:14:24 -040027SYSTEMD_SERVICE_${PN} = " \
Vishwanatha Subbannae4bfd682016-10-01 11:34:42 -050028 ${PN}@.service \
29 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
Brad Bishopf75c9602016-08-30 14:14:24 -040030 ${PN}-ssh.socket \
31 ${PN}-ssh@.service \
32 "
Jeremy Kerr882199e2016-03-17 17:35:27 +080033do_install_append() {
34 install -m 0755 -d ${D}${sysconfdir}
35 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr882199e2016-03-17 17:35:27 +080036}
37
38S = "${WORKDIR}/git"