blob: 59692ecb8257dbd96a047f7f073005e491c3994a [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC gdbus library"
2DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
3methods and the GDBUS skeleton code for the org.openbmc DBUS API."
4PR = "r1"
Patrick Venture78882612018-10-23 08:59:23 -07005PV = "1.0+git${SRCPV}"
Brad Bishop5f9be072016-06-27 14:53:52 -04006
7inherit skeleton
Saqib Khan02917df2017-11-13 10:47:54 -06008inherit pkgconfig
Brad Bishop5f9be072016-06-27 14:53:52 -04009
10DEPENDS += "glib-2.0"
Matt Spinler71c1c922018-08-07 16:35:19 -050011DEPENDS += "cjson"
Brad Bishop5f9be072016-06-27 14:53:52 -040012
13SKELETON_DIR = "libopenbmc_intf"
14
Matt Spinler71c1c922018-08-07 16:35:19 -050015SRC_URI += "file://gpio_defs.json"
16
Brad Bishop5f9be072016-06-27 14:53:52 -040017do_install() {
18 oe_runmake install DESTDIR=${D}
Matt Spinler71c1c922018-08-07 16:35:19 -050019
20 install -d ${D}${sysconfdir}/default/obmc/gpio/
21 install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
Brad Bishop5f9be072016-06-27 14:53:52 -040022}