blob: c82965ffa197c0f64d1f18254eb86b3d0c260004 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler78b72792022-06-14 06:47:25 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012
Andrew Geissler78b72792022-06-14 06:47:25 -050013SRC_URI[sha256sum] = "917223b37538959aca3b790d2d73aa6e626b688e02dcda272aec24c2f498abed"
Brad Bishop19323692019-04-05 15:28:33 -040014
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
William A. Kennington IIIac69b482021-06-02 12:28:27 -070018# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
19# and 4.3.0 doesn't have the issue
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020CVE_CHECK_IGNORE += "CVE-2015-7313"
Andrew Geissler78b72792022-06-14 06:47:25 -050021# These issues only affect libtiff post-4.3.0 but before 4.4.0,
22# caused by 3079627e and fixed by b4e79bfa.
23CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
24
25# Issue is in jbig which we don't enable
26CVE_CHECK_IGNORE += "CVE-2022-1210"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070027
Brad Bishop19323692019-04-05 15:28:33 -040028inherit autotools multilib_header
29
30CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
31
32PACKAGECONFIG ?= "cxx jpeg zlib lzma \
33 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
34
35PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
Andrew Geissler78b72792022-06-14 06:47:25 -050036PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
Brad Bishop19323692019-04-05 15:28:33 -040037PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
38PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
39PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
40
41# Convert single-strip uncompressed images to multiple strips of specified
42# size (default: 8192) to reduce memory usage
43PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
44
45# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
46PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
47
48# Control picking up YCbCr subsample info. Disable to support files lacking
49# the tag
50PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
51
52# Support a mechanism allowing reading large strips (usually one strip files)
53# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
54PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
55
56PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050057FILES:tiffxx = "${libdir}/libtiffxx.so.*"
58FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040059
Patrick Williams213cb262021-08-07 19:21:33 -050060do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040061 oe_multilib_header tiffconf.h
62}
63
Andrew Geissler4ed12e12020-06-05 18:00:41 -050064BBCLASSEXTEND = "native nativesdk"