blob: 6b933a409b886e78e7caf93171ae95ac0e399ed2 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012 file://0001-tiffset-fix-global-buffer-overflow-for-ASCII-tags-wh.patch \
13 file://561599c99f987dc32ae110370cfdd7df7975586b.patch \
14 file://eecb0712f4c3a5b449f70c57988260a667ddbdef.patch"
15
Andrew Geisslerc926e172021-05-07 16:11:35 -050016SRC_URI[sha256sum] = "0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8"
Brad Bishop19323692019-04-05 15:28:33 -040017
18# exclude betas
19UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
20
William A. Kennington IIIac69b482021-06-02 12:28:27 -070021# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
22# and 4.3.0 doesn't have the issue
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023CVE_CHECK_IGNORE += "CVE-2015-7313"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070024
Brad Bishop19323692019-04-05 15:28:33 -040025inherit autotools multilib_header
26
27CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
28
29PACKAGECONFIG ?= "cxx jpeg zlib lzma \
30 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
31
32PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
33PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
34PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
35PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
36
37# Convert single-strip uncompressed images to multiple strips of specified
38# size (default: 8192) to reduce memory usage
39PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
40
41# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
42PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
43
44# Control picking up YCbCr subsample info. Disable to support files lacking
45# the tag
46PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
47
48# Support a mechanism allowing reading large strips (usually one strip files)
49# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
50PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
51
52PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050053FILES:tiffxx = "${libdir}/libtiffxx.so.*"
54FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040055
Patrick Williams213cb262021-08-07 19:21:33 -050056do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040057 oe_multilib_header tiffconf.h
58}
59
Andrew Geissler4ed12e12020-06-05 18:00:41 -050060BBCLASSEXTEND = "native nativesdk"