blob: 8acb699d4ab2bcd05ae0796bb0b675da579dcd62 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "A portable foreign function interface library"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://sourceware.org/libffi/"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05003DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b"
12
Brad Bishopc68388fc2019-08-26 01:33:31 -040013SRC_URI = "https://github.com/libffi/libffi/releases/download/v3.3-rc0/libffi-3.3-rc0.tar.gz \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://not-win32.patch \
Brad Bishop79641f22019-09-10 07:20:22 -040015 file://0001-Fixed-missed-ifndef-for-__mips_soft_float.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040016 "
Brad Bishopc68388fc2019-08-26 01:33:31 -040017SRC_URI[md5sum] = "8d2a82a78faf10a5e53c27d986e8f04e"
18SRC_URI[sha256sum] = "403d67aabf1c05157855ea2b1d9950263fb6316536c8c333f5b9ab1eb2f20ecf"
Brad Bishop79641f22019-09-10 07:20:22 -040019UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
20UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
21UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050022
23EXTRA_OECONF += "--disable-builddir"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
Brad Bishopc68388fc2019-08-26 01:33:31 -040025inherit autotools texinfo multilib_header
26
27S = "${WORKDIR}/${BPN}-3.3-rc0"
28
29do_install_append() {
30 oe_multilib_header ffi.h
31}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050032
33FILES_${PN}-dev += "${libdir}/libffi-${PV}"
34
Patrick Williamsc0f7c042017-02-23 20:41:17 -060035# Doesn't compile in MIPS16e mode due to use of hand-written
36# assembly
37MIPS_INSTRUCTION_SET = "mips"
38
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039BBCLASSEXTEND = "native nativesdk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040