blob: 906f6654a5d73ecf227143351b2dd8bd99d04fda [file] [log] [blame]
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05301SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
Patrick Venturea1a628b2018-10-01 20:48:41 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venturea1a628b2018-10-01 20:48:41 -07008
William A. Kennington III7d98c922019-03-28 03:38:35 -07009inherit meson pkgconfig
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053010inherit obmc-phosphor-dbus-service
11
12RPROVIDES_${PN} += "virtual/obmc-watchdog"
13PROVIDES += "virtual/obmc-watchdog"
14
William A. Kennington IIIf33e9a12018-09-14 00:25:00 -070015DEPENDS += "cli11"
William A. Kennington IIIf37d0962019-03-27 20:21:26 -070016DEPENDS += "sdbusplus"
William A. Kennington III83d610a2018-09-13 23:32:19 -070017DEPENDS += "sdeventplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053018DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "phosphor-logging"
Brad Bishop44f3cce2019-03-22 23:41:42 -040020DEPENDS += "systemd"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053021
22SRC_URI += "git://github.com/openbmc/phosphor-watchdog"
Andrew Geissler1e6c9352019-04-05 23:35:57 +000023SRCREV = "26eef26c97beec18d0f96fd1cd792229caded542"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053024S = "${WORKDIR}/git"
25
William A. Kennington III7d98c922019-03-28 03:38:35 -070026EXTRA_OEMESON = " \
27 -Dtests=disabled \
28 "
29
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053030# Copies config file having arguments for host watchdog
31SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron"
32
33# Install the override to set up a Conflicts relation
34SYSTEMD_OVERRIDE_${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
35
36# For now, watching PowerOn is the only usecase
37OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
38
39# This is really a DBUS service but the service name is
40# an argument, so making it this way.
41WATCHDOG_TMPL = "phosphor-watchdog@.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053042ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053043SYSTEMD_SERVICE_${PN} += "${WATCHDOG_TMPL}"
44
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053045# To Enable Host Watchdog early during poweron
46SYSTEMD_SERVICE_${PN} += "${ENABLE_WATCHDOG_TMPL}"
47
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053048WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053049ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
50
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070051WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}"
52ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053053
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053054SYSTEMD_LINK_${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053055SYSTEMD_LINK_${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"