blob: 7e5860c18cd63db674b82473593cfc0356b719ab [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Helper tool used when compiling"
2DESCRIPTION = "pkg-config is a helper tool used when compiling applications and libraries. It helps determined \
3the correct compiler/link options. It is also language-agnostic."
4HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
5BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=pkg-config"
6SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-or-later"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
Andrew Geisslereff27472021-10-29 15:35:00 -050011SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012PV = "0.29.2+git${SRCPV}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013
William A. Kennington IIIac69b482021-06-02 12:28:27 -070014SRC_URI = "git://gitlab.freedesktop.org/pkg-config/pkg-config.git;branch=master;protocol=https \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 file://pkg-config-esdk.in \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016 file://pkg-config-native.in \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017 file://0001-glib-gettext.m4-Update-AM_GLIB_GNU_GETTEXT-to-match-.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050018 file://0001-autotools-remove-support-for-the-__int64-type.-See-1.patch \
19 file://0001-autotools-use-C99-printf-format-specifiers-on-Window.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050021
22S = "${WORKDIR}/git"
23
24inherit autotools
25
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026# Because of a faulty test, the current auto mode always evaluates to no,
27# so just continue that behaviour.
28#
29EXTRA_OECONF += "--disable-indirect-deps"
30
31PACKAGECONFIG ??= "glib"
Patrick Williams213cb262021-08-07 19:21:33 -050032PACKAGECONFIG:class-native = ""
33PACKAGECONFIG:class-nativesdk = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034
35PACKAGECONFIG[glib] = "--without-internal-glib,--with-internal-glib,glib-2.0 pkgconfig-native"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050036
37acpaths = "-I ."
38
39BBCLASSEXTEND = "native nativesdk"
40
41# Set an empty dev package to ensure the base PN package gets
42# the pkg.m4 macros, pkgconfig does not deliver any other -dev
43# files.
Patrick Williams213cb262021-08-07 19:21:33 -050044FILES:${PN}-dev = ""
45FILES:${PN} += "${datadir}/aclocal/pkg.m4"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050046
47# When using the RPM generated automatic package dependencies, some packages
48# will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by
49# specifying an appropriate provide.
Patrick Williams213cb262021-08-07 19:21:33 -050050RPROVIDES:${PN} += "pkgconfig(pkg-config)"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051
52# Install a pkg-config-native wrapper that will use the native sysroot instead
53# of the MACHINE sysroot, for using pkg-config when building native tools.
Patrick Williams213cb262021-08-07 19:21:33 -050054do_install:append:class-native () {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050055 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
56 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
57 < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native
58 install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native
Brad Bishopd7bf8c12018-02-25 22:55:05 -050059 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
60 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
61 < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk
62 install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050063}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050064
65pkgconfig_sstate_fixup_esdk () {
66 if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then
67 pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}"
68 mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real
Andrew Geissler595f6302022-01-24 19:11:47 +000069 ln -rs $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config
Brad Bishopd7bf8c12018-02-25 22:55:05 -050070 sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native
71 fi
72}
73
Patrick Williams213cb262021-08-07 19:21:33 -050074SSTATEPOSTUNPACKFUNCS:append:class-native = " pkgconfig_sstate_fixup_esdk"