blob: 5a1d329993029649a13c2a01be224a56eccc04e4 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04008LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
Patrick Williams93c203f2021-10-06 16:15:23 -050010SRCREV = "bcb82804daa8f725b6add259dcef2067e61a75aa"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050011PV .= "+git${SRCPV}"
Brad Bishop19323692019-04-05 15:28:33 -040012
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master \
Brad Bishop15ae2502019-06-18 21:44:24 -040014"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040015
Brad Bishop19323692019-04-05 15:28:33 -040016S = "${WORKDIR}/git"
17
Andrew Geisslereff27472021-10-29 15:35:00 -050018FILES:${PN} = "${bindir}/ptest-runner ${bindir}/ptest-runner-collect-system-data"
Brad Bishop19323692019-04-05 15:28:33 -040019
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
Andrew Geisslereff27472021-10-29 15:35:00 -050028 install -D -m 0755 ${S}/ptest-runner-collect-system-data ${D}${bindir}/ptest-runner-collect-system-data
Brad Bishop19323692019-04-05 15:28:33 -040029}
Andrew Geisslerc926e172021-05-07 16:11:35 -050030
Patrick Williams213cb262021-08-07 19:21:33 -050031RDEPENDS:${PN}:append:libc-glibc = " libgcc"
Andrew Geisslereff27472021-10-29 15:35:00 -050032
33# pstree is called by ptest-runner-collect-system-data
34RDEPENDS:${PN}:append = " pstree"