blob: f57767e9b8ad5ea847882107bcafe6c8eabff1ba [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Dibbler DHCPv6 client"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
3HOMEPAGE = "http://klub.com.pl/dhcpv6"
4
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
7
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/tomaszmrugalski/dibbler;branch=master;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 file://dibbler_fix_getSize_crash.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://0001-port-linux-Re-order-header-includes.patch \
Brad Bishop19323692019-04-05 15:28:33 -040013 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014PV = "1.0.1+1.0.2RC1+git${SRCREV}"
15
16S = "${WORKDIR}/git"
17
18PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update"
19
20PACKAGECONFIG[debug] = "--enable-debug,,,"
21PACKAGECONFIG[efence] = "--enable-efence,,,"
22PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,,"
23PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,,"
24PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,,"
25PACKAGECONFIG[dns-update] = "--enable-dns-update,,,"
26PACKAGECONFIG[auth] = "--enable-auth,,,"
27PACKAGECONFIG[gtest] = "--enable-gtest-static,,,"
28
29inherit autotools
30
31DEPENDS += "flex-native"
32
Patrick Williams92b42cb2022-09-03 06:53:57 -050033CFLAGS += "-D_GNU_SOURCE"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050034LDFLAGS += "-pthread"
35
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038FILES:${PN}-client = "${sbindir}/${PN}-client"
39FILES:${PN}-relay = "${sbindir}/${PN}-relay"
40FILES:${PN}-requestor = "${sbindir}/${PN}-requestor"
41FILES:${PN}-server = "${sbindir}/${PN}-server"