blob: 9d3a0e6cb58f30827067097913cbf45e810469f9 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
13LICENSE = "BSD & LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
Brad Bishop15ae2502019-06-18 21:44:24 -040016PV = "0.14.2+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
19SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21SRCREV_FORMAT = "spice_spice-common"
22
23SRC_URI = " \
24 git://anongit.freedesktop.org/spice/spice;name=spice \
25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \
26 file://0001-Convert-pthread_t-to-be-numeric.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040027 file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028"
29
30S = "${WORKDIR}/git"
31
Andrew Geissler82c905d2020-04-13 13:39:40 -050032inherit autotools gettext python3native python3-dir pkgconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
Andrew Geissler82c905d2020-04-13 13:39:40 -050034DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035DEPENDS_append_class-nativesdk = "nativesdk-openssl"
36
Andrew Geissler82c905d2020-04-13 13:39:40 -050037export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
Brad Bishop36a3e3e2019-10-02 13:29:27 -040039CFLAGS_append = " -Wno-error"
Brad Bishop15ae2502019-06-18 21:44:24 -040040
Brad Bishop36a3e3e2019-10-02 13:29:27 -040041PACKAGECONFIG_class-native = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042PACKAGECONFIG_class-nativesdk = ""
43PACKAGECONFIG ?= "sasl"
44
45PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
46PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
47PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
48PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
49PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
50PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
51PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
52PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
53
54COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
55
Brad Bishop36a3e3e2019-10-02 13:29:27 -040056BBCLASSEXTEND = "native nativesdk"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057
Brad Bishop15ae2502019-06-18 21:44:24 -040058EXTRA_OECONF_append_toolchain-clang = " --disable-werror"