blob: 39ceb489e2e25eee12047d6ebea3d424b1e9ea37 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "p8platform udev ncurses swig-native python3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Andrew Geissler82c905d2020-04-13 13:39:40 -050012PV = "5.0.0"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Andrew Geissler82c905d2020-04-13 13:39:40 -050014SRCREV = "43bc27fe7be491149e6f57d14110e02abdac2f24"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \
Brad Bishope42b3e32020-01-15 22:08:42 -050016 file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 file://0001-Enhance-reproducibility.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050018 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019
20S = "${WORKDIR}/git"
21
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022inherit cmake pkgconfig
23
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024# Put client tools into a separate package
25PACKAGE_BEFORE_PN += "${PN}-tools"
26FILES_${PN}-tools = "${bindir}"
Brad Bishop90ca7472019-08-20 09:15:15 -040027RDEPENDS_${PN}-tools = "python3-${BPN} python3-core"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029# Create the wrapper for python3
30PACKAGES += "python3-${BPN}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
32RDEPENDS_${PN} = "python3-core"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050033
34# cec-client and xbmc need the .so present to work :(
35FILES_${PN} += "${libdir}/*.so"
36INSANE_SKIP_${PN} = "dev-so"
37
38# Adapter shows up as a CDC-ACM device
39RRECOMMENDS_${PN} = "kernel-module-cdc-acm"